aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gvolwheel/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-02-10 22:09:08 +0800
committermiwi <miwi@FreeBSD.org>2013-02-10 22:09:08 +0800
commit2c7623196e6cc152aac9f92488ad4376f3273420 (patch)
treeee8e62f0b4fa4c8f3bbff929e94837138d168c7e /audio/gvolwheel/Makefile
parent4c66749de7a495ba176a4e26bd86a89f4d649e87 (diff)
downloadfreebsd-ports-gnome-2c7623196e6cc152aac9f92488ad4376f3273420.tar.gz
freebsd-ports-gnome-2c7623196e6cc152aac9f92488ad4376f3273420.tar.zst
freebsd-ports-gnome-2c7623196e6cc152aac9f92488ad4376f3273420.zip
GVolWheel is a Lightweight application which lets you control the audio
volume. GVolWheel is application which lets you control the volume easily through a tray icon you can scroll on. Easily integrate with minimal desktops (Openbox,IceWM,XFCE etc). WWW: http://sourceforge.net/projects/gvolwheel/ PR: ports/175887 Submitted by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
Diffstat (limited to 'audio/gvolwheel/Makefile')
-rw-r--r--audio/gvolwheel/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/audio/gvolwheel/Makefile b/audio/gvolwheel/Makefile
new file mode 100644
index 000000000000..f8189077fda4
--- /dev/null
+++ b/audio/gvolwheel/Makefile
@@ -0,0 +1,41 @@
+# Created by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+# $FreeBSD$
+
+PORTNAME= gvolwheel
+PORTVERSION= 1.0
+CATEGORIES= audio
+MASTER_SITES= SF/${PORTNAME}
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Volume mixer
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= intltoolize:${PORTSDIR}/textproc/intltool
+
+CONFIGURE_ARGS+=--enable-oss
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gtk30
+USE_ICONV= yes
+USE_PKGCONFIG= yes
+
+OPTIONS_DEFINE= NLS
+NLS_DESC= Native language support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+PLIST_SUB+= NLS=""
+USE_GETTEXT= yes
+.endif
+
+pre-configure:
+ ${ECHO} "${DOCSDIR}"
+ ${REINPLACE_CMD} -e 's|linux/soundcard|sys/soundcard|g' \
+ ${WRKSRC}/src/callbacks.c ${WRKSRC}/src/actions.c
+
+.include <bsd.port.mk>