aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gvolwheel/Makefile
diff options
context:
space:
mode:
authorvg <vg@FreeBSD.org>2013-08-20 05:25:22 +0800
committervg <vg@FreeBSD.org>2013-08-20 05:25:22 +0800
commitcd28fc10b0b0fb81ca46508a7228f65e34e20e69 (patch)
tree61cbb941dcb970da9ba407d10e3ab5600a3047d7 /audio/gvolwheel/Makefile
parent7bc172e31e171ba531e93388625b8383211e25e1 (diff)
downloadfreebsd-ports-gnome-cd28fc10b0b0fb81ca46508a7228f65e34e20e69.tar.gz
freebsd-ports-gnome-cd28fc10b0b0fb81ca46508a7228f65e34e20e69.tar.zst
freebsd-ports-gnome-cd28fc10b0b0fb81ca46508a7228f65e34e20e69.zip
- Bump portrevision
- USES gmake pkgconfig pathfix icon - Add docs - Trim NLS - Add DOCS and NLS Option - Add Desktop entry file - Add patch linux/soundcard --> sys/soundcard - Add Icons - Trim WWW - Trim pkg-plist, remove docs PR: ports/181180 Submitted by: nemysis <nemysis@gmx.ch> Approved by: eadler (mentor)
Diffstat (limited to 'audio/gvolwheel/Makefile')
-rw-r--r--audio/gvolwheel/Makefile40
1 files changed, 26 insertions, 14 deletions
diff --git a/audio/gvolwheel/Makefile b/audio/gvolwheel/Makefile
index c825aa0e0efd..b3014cbb83cd 100644
--- a/audio/gvolwheel/Makefile
+++ b/audio/gvolwheel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gvolwheel
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}
@@ -15,26 +16,37 @@ BUILD_DEPENDS= intltoolize:${PORTSDIR}/textproc/intltool
CONFIGURE_ARGS+=--enable-oss
GNU_CONFIGURE= yes
-USES= pkgconfig pathfix iconv
-USE_GMAKE= yes
+USES= gmake iconv pathfix pkgconfig
USE_GNOME= gtk30
-OPTIONS_DEFINE= NLS
-NLS_DESC= Native language support
+PORTDOCS= AUTHORS ChangeLog README
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MNLS}
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-PLIST_SUB+= NLS=""
-USES+= gettext
-.endif
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
+
+SUB_FILES= pkg-message
-pre-configure:
- ${ECHO} "${DOCSDIR}"
+DESKTOP_ENTRIES="GVolWheel" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "GTK;AudioVideo;Audio;Mixer;" true
+
+.include <bsd.port.options.mk>
+
+post-patch:
${REINPLACE_CMD} -e 's|linux/soundcard|sys/soundcard|g' \
${WRKSRC}/src/callbacks.c ${WRKSRC}/src/actions.c
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+ ${LN} -sf ${PREFIX}/share/pixmaps/gvolwheel/audio-volume-high.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
.include <bsd.port.mk>