aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gxmms2/Makefile
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-03-16 05:25:38 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-03-16 05:25:38 +0800
commitf0c598c4c986f7e4e72f245f1305c1d9dba9c06c (patch)
tree3646a115adca7b6f6fb70a7b1cb62db54ec7596f /audio/gxmms2/Makefile
parentee897a293ea12bcfac11e540c83667b409a3348d (diff)
downloadfreebsd-ports-gnome-f0c598c4c986f7e4e72f245f1305c1d9dba9c06c.tar.gz
freebsd-ports-gnome-f0c598c4c986f7e4e72f245f1305c1d9dba9c06c.tar.zst
freebsd-ports-gnome-f0c598c4c986f7e4e72f245f1305c1d9dba9c06c.zip
Add gxmms2 0.6.1, a GTK2 based XMMS2 client, written in C.
PR: 94437 Submitted by: Alexander Botero-Lowry <alex@foxybanana.com>
Diffstat (limited to 'audio/gxmms2/Makefile')
-rw-r--r--audio/gxmms2/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/audio/gxmms2/Makefile b/audio/gxmms2/Makefile
new file mode 100644
index 000000000000..cfe3d789d4cd
--- /dev/null
+++ b/audio/gxmms2/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: gxmms2
+# Date created: 03 Mar 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gxmms2
+PORTVERSION= 0.6.1
+CATEGORIES= audio
+MASTER_SITES= http://wejp.mooo.com/wejp/xmms2/
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= A GTK2 based XMMS2 client, written in C
+
+RUN_DEPENDS= ${LOCALBASE}/bin/xmms2:${PORTSDIR}/audio/xmms2
+BUILD_DEPENDS= ${LOCALBASE}/lib/libxmmsclient.so:${PORTSDIR}/audio/xmms2
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk20
+
+ALL_TARGET= ${PORTNAME}
+PLIST_FILES= bin/gxmms2
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not build on FreeBSD 4.x
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.post.mk>