aboutsummaryrefslogtreecommitdiffstats
path: root/audio/hexter/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-01-25 04:42:18 +0800
committermiwi <miwi@FreeBSD.org>2007-01-25 04:42:18 +0800
commitc81a706453a8c87ec3d5d9266d2db6786f65fcf2 (patch)
treea3e7806caac971894113e722d570a4f9ef7d1443 /audio/hexter/Makefile
parent944f05e00b9f3bf57d4effd1f49b4d685a12568b (diff)
downloadfreebsd-ports-gnome-c81a706453a8c87ec3d5d9266d2db6786f65fcf2.tar.gz
freebsd-ports-gnome-c81a706453a8c87ec3d5d9266d2db6786f65fcf2.tar.zst
freebsd-ports-gnome-c81a706453a8c87ec3d5d9266d2db6786f65fcf2.zip
hexter is a software synthesizer that models the sound generation
of a Yamaha DX7 synthesizer. It can easily load most DX7 patch bank files, accept patch editing commands via MIDI sys-ex messages (ALSA systems only), and recreate the sound of the DX7 with greater accuracy than any previous open-source emulation (that the author is aware of....) hexter operates as a plugin for the Disposable Soft Synth Interface (DSSI). WWW: http://dssi.sourceforge.net/hexter.html PR: ports/108147 Submitted by: trasz <trasz at pin.if.uz.zgora.pl>
Diffstat (limited to 'audio/hexter/Makefile')
-rw-r--r--audio/hexter/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/audio/hexter/Makefile b/audio/hexter/Makefile
new file mode 100644
index 000000000000..d9c27f2d23ed
--- /dev/null
+++ b/audio/hexter/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: hexter
+# Date created: 2007-01-20
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hexter
+PORTVERSION= 0.5.9
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= dssi
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= DSSI softsynth that models the sound generation of a Yamaha DX7
+
+LIB_DEPENDS= dssialsacompat.0:${PORTSDIR}/audio/libdssialsacompat \
+ lo.6:${PORTSDIR}/audio/liblo \
+ jack.0:${PORTSDIR}/audio/jack
+BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
+
+.include <bsd.port.mk>