aboutsummaryrefslogtreecommitdiffstats
path: root/audio/hydrogen
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2008-04-08 04:37:23 +0800
committernaddy <naddy@FreeBSD.org>2008-04-08 04:37:23 +0800
commit5d7648cf54a89e826350ff1b2f40131f20c43261 (patch)
tree2ef2e56717d3ec99a2689360c25c64d5cae8418d /audio/hydrogen
parentac39987147fb57e12b7fc719185f6a8153a068d7 (diff)
downloadfreebsd-ports-gnome-5d7648cf54a89e826350ff1b2f40131f20c43261.tar.gz
freebsd-ports-gnome-5d7648cf54a89e826350ff1b2f40131f20c43261.tar.zst
freebsd-ports-gnome-5d7648cf54a89e826350ff1b2f40131f20c43261.zip
Update to FLAC 1.2.1. This version includes two and a half years
worth of changes and an altered API. Bump the revision of all ports that depend on libFLAC and adapt to the new API where necessary. Some patches from Debian, Gentoo, OpenBSD, and upstream repositories. PR: 119476
Diffstat (limited to 'audio/hydrogen')
-rw-r--r--audio/hydrogen/Makefile8
-rw-r--r--audio/hydrogen/files/patch-src_lib_FLACFile.cpp21
2 files changed, 26 insertions, 3 deletions
diff --git a/audio/hydrogen/Makefile b/audio/hydrogen/Makefile
index c3c232d14566..f6322800d88a 100644
--- a/audio/hydrogen/Makefile
+++ b/audio/hydrogen/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hydrogen
PORTVERSION= 0.9.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -42,6 +42,8 @@ OPTIONS= JACK "JACK support" off \
LRDF "LRDF support" off \
FLAC "FLAC support" on
+.include <bsd.port.pre.mk>
+
.if defined(WITH_JACK)
LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
CPPFLAGS+= ${PTHREAD_CFLAGS}
@@ -66,7 +68,7 @@ CONFIGURE_ARGS+=--disable-lrdf-support
.endif
.if defined(WITH_FLAC)
-LIB_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac
+LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
.else
CONFIGURE_ARGS+=--disable-flac-support
.endif
@@ -110,4 +112,4 @@ do-install:
${MKDIR} ${MAN1PREFIX}/man/ru.KOI8-R/man1
${INSTALL_MAN} ${WRKSRC}/man/ru/hydrogen.1 ${MAN1PREFIX}/man/ru.KOI8-R/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/hydrogen/files/patch-src_lib_FLACFile.cpp b/audio/hydrogen/files/patch-src_lib_FLACFile.cpp
new file mode 100644
index 000000000000..f66d829bde2a
--- /dev/null
+++ b/audio/hydrogen/files/patch-src_lib_FLACFile.cpp
@@ -0,0 +1,21 @@
+--- src/lib/FLACFile.cpp.orig 2008-03-27 21:03:52.000000000 +0100
++++ src/lib/FLACFile.cpp 2008-03-27 21:05:03.000000000 +0100
+@@ -164,15 +164,13 @@ void FLACFile_real::load( string sFilena
+ }
+
+ set_metadata_ignore_all();
+- set_filename( sFilename.c_str() );
+
+- State s=init();
+- if( s != FLAC__FILE_DECODER_OK ) {
++ if( FLAC__STREAM_DECODER_INIT_STATUS_OK != init( sFilename.c_str() ) ) {
+ errorLog( "[load] Error in init()" );
+ }
+
+- if ( process_until_end_of_file() == false ) {
+- errorLog( "[load] Error in process_until_end_of_file()" );
++ if ( process_until_end_of_stream() == false ) {
++ errorLog( "[load] Error in process_until_end_of_stream()" );
+ }
+ }
+