aboutsummaryrefslogtreecommitdiffstats
path: root/audio/icecast/Makefile
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-08-21 10:52:01 +0800
committerpat <pat@FreeBSD.org>2002-08-21 10:52:01 +0800
commitd807df6cfaf5be28e732899e19fe5458de82d9e4 (patch)
treeb9b4b77b1311b1775346e96ec91411977edba210 /audio/icecast/Makefile
parenta44aac548589eee7d07dd1945f2e61b5424dee24 (diff)
downloadfreebsd-ports-gnome-d807df6cfaf5be28e732899e19fe5458de82d9e4.tar.gz
freebsd-ports-gnome-d807df6cfaf5be28e732899e19fe5458de82d9e4.tar.zst
freebsd-ports-gnome-d807df6cfaf5be28e732899e19fe5458de82d9e4.zip
- Fix detection of libreadline and bump PORTREVISION [1]
- Allow port to compile on -current Submitted by: David Yeske <dyeske@yahoo.com> [1] Reviewed by: maintainer
Diffstat (limited to 'audio/icecast/Makefile')
-rw-r--r--audio/icecast/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/audio/icecast/Makefile b/audio/icecast/Makefile
index 822bd1c4b949..704cb8a95e69 100644
--- a/audio/icecast/Makefile
+++ b/audio/icecast/Makefile
@@ -7,6 +7,7 @@
PORTNAME= icecast
PORTVERSION= 1.3.12
+PORTREVISION= 1
CATEGORIES= audio net
MASTER_SITES= http://www.icecast.org/releases/
@@ -14,6 +15,14 @@ MAINTAINER= zach@pabst.bendnet.com
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --with-libwrap
+USE_REINPLACE= yes
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's|<history.h>|<readline/history.h>|' \
+ -e 's|<readline.h>|<readline/readline.h>|' \
+ ${WRKSRC}/src/admin.c
+ @${REINPLACE_CMD} -e 's|#undef HAVE_HISTORY_H|#undef HAVE_READLINE_HISTORY_H|g' \
+ ${WRKSRC}/config.h.in
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/icecast ${PREFIX}/sbin