aboutsummaryrefslogtreecommitdiffstats
path: root/audio/icegenerator
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-08-31 04:14:02 +0800
committermadpilot <madpilot@FreeBSD.org>2013-08-31 04:14:02 +0800
commit8e339785094ceb1565f32e0bb16c015e6d8b7d34 (patch)
tree3efddc307d6dc9dc0b64b19759d20b9e652f93f9 /audio/icegenerator
parentb691779272e97c051e926b0de557550ccacd91e0 (diff)
downloadfreebsd-ports-gnome-8e339785094ceb1565f32e0bb16c015e6d8b7d34.tar.gz
freebsd-ports-gnome-8e339785094ceb1565f32e0bb16c015e6d8b7d34.tar.zst
freebsd-ports-gnome-8e339785094ceb1565f32e0bb16c015e6d8b7d34.zip
- Add OPTIONS support, with options to enable MySQL and PostgreSQL backends
While here: - Trim makefile headers - Convert to new LIB_DEPENDS format and remove ABI version number - Use USES=gmake PR: ports/181295 Submitted by: Me Approved by: Maintainer timeout
Diffstat (limited to 'audio/icegenerator')
-rw-r--r--audio/icegenerator/Makefile26
1 files changed, 18 insertions, 8 deletions
diff --git a/audio/icegenerator/Makefile b/audio/icegenerator/Makefile
index 54343e6d627e..ee779209620a 100644
--- a/audio/icegenerator/Makefile
+++ b/audio/icegenerator/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: icegenerator
-# Date created: 18 August 2004
-# Whom: Nadelyaev Stanislav <funkblaster@n11.bmstu.ru>
-#
+# Created by: Nadelyaev Stanislav <funkblaster@n11.bmstu.ru>
# $FreeBSD$
-#
PORTNAME= icegenerator
DISTVERSION= 0.5.5-pre2
@@ -13,14 +9,28 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.5.5-pre2
MAINTAINER= funkblaster@mail.ru
COMMENT= Direct streaming generator for Icecast/Shoutcast
-LIB_DEPENDS= shout.5:${PORTSDIR}/audio/libshout2
+LIB_DEPENDS= libshout.so:${PORTSDIR}/audio/libshout2
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
CONFIGURE_ARGS= --exec-prefix=${PREFIX}
+OPTIONS_DEFINE= DOCS MYSQL PGSQL
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMYSQL}
+USE_MYSQL= YES
+CONFIGURE_ARGS+= --with-mysql
+.endif
+
+.if ${PORT_OPTIONS:MPGSQL}
+USE_PGSQL= YES
+CONFIGURE_ARGS+= --with-pgsql
+.endif
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
.endif