aboutsummaryrefslogtreecommitdiffstats
path: root/audio/id3lib/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-12-21 15:07:39 +0800
committerwill <will@FreeBSD.org>2000-12-21 15:07:39 +0800
commit48f8ea30bfef959a1d1a0bb49b594ede341f6d02 (patch)
tree18ea3e69c7fd58ba7f0b06456db831e3f700c156 /audio/id3lib/Makefile
parentf5444e73cb0b4ce01932a1a503976af2780a307e (diff)
downloadfreebsd-ports-gnome-48f8ea30bfef959a1d1a0bb49b594ede341f6d02.tar.gz
freebsd-ports-gnome-48f8ea30bfef959a1d1a0bb49b594ede341f6d02.tar.zst
freebsd-ports-gnome-48f8ea30bfef959a1d1a0bb49b594ede341f6d02.zip
Make id3lib use libtool correctly. Use automake/autoconf along with a patch
to configure.in instead of configure. Sort plist. Remove redundate GNU_CONFIGURE. Use LOCALBASE in CONFIGURE_ENV rather than PREFIX. PR: 22584 Submitted by: Espen Skoglund <esk@ira.uka.de>
Diffstat (limited to 'audio/id3lib/Makefile')
-rw-r--r--audio/id3lib/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/audio/id3lib/Makefile b/audio/id3lib/Makefile
index 88fe86145e4e..ec784810fcd6 100644
--- a/audio/id3lib/Makefile
+++ b/audio/id3lib/Makefile
@@ -16,8 +16,11 @@ MAINTAINER= roman@xpert.com
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="-L${PREFIX}/lib" CPPFLAGS="-I${PREFIX}/include"
+USE_LIBTOOL= yes
+USE_AUTOMAKE= yes
+USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
post-extract:
.for i in zlib popt