aboutsummaryrefslogtreecommitdiffstats
path: root/audio/id3v2
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-01-07 12:56:15 +0800
committeredwin <edwin@FreeBSD.org>2003-01-07 12:56:15 +0800
commit00cd0d70cbab82ad1f3479c62dfaa8d05a9b7166 (patch)
tree14980a7c98981d99af975fed419fa87b30d6c8b9 /audio/id3v2
parent8be36dff87e3267cc5edd6b7d5a632c71a08d163 (diff)
downloadfreebsd-ports-gnome-00cd0d70cbab82ad1f3479c62dfaa8d05a9b7166.tar.gz
freebsd-ports-gnome-00cd0d70cbab82ad1f3479c62dfaa8d05a9b7166.tar.zst
freebsd-ports-gnome-00cd0d70cbab82ad1f3479c62dfaa8d05a9b7166.zip
Update of audio/id3lib to 3.8.2
PR: several Submitted by: Roman Shterenzon <roman@xpert.com> and others
Diffstat (limited to 'audio/id3v2')
-rw-r--r--audio/id3v2/Makefile8
-rw-r--r--audio/id3v2/distinfo2
-rw-r--r--audio/id3v2/files/patch-aa33
-rw-r--r--audio/id3v2/files/patch-ab74
-rw-r--r--audio/id3v2/files/patch-ac77
5 files changed, 24 insertions, 170 deletions
diff --git a/audio/id3v2/Makefile b/audio/id3v2/Makefile
index e7c0a63d6ad6..1bd555796039 100644
--- a/audio/id3v2/Makefile
+++ b/audio/id3v2/Makefile
@@ -6,13 +6,15 @@
#
PORTNAME= id3v2
-PORTVERSION= 0.1.2
+PORTVERSION= 0.1.7
CATEGORIES= audio
-MASTER_SITES= http://download.sourceforge.net/id3v2/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= id3v2
MAINTAINER= djm@pix.net
-LIB_DEPENDS= id3:${PORTSDIR}/audio/id3lib gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= id3-3.8.2:${PORTSDIR}/audio/id3lib \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
MAN1= id3v2.1
diff --git a/audio/id3v2/distinfo b/audio/id3v2/distinfo
index 982c101ac1f0..8a55cf8e31d6 100644
--- a/audio/id3v2/distinfo
+++ b/audio/id3v2/distinfo
@@ -1 +1 @@
-MD5 (id3v2-0.1.2.tar.gz) = 6bc856e78da102c2f012db63d516806e
+MD5 (id3v2-0.1.7.tar.gz) = 825cf4baf60e2951b7826b947a8f52fa
diff --git a/audio/id3v2/files/patch-aa b/audio/id3v2/files/patch-aa
index c28b486e1d59..13ca63b4dfdd 100644
--- a/audio/id3v2/files/patch-aa
+++ b/audio/id3v2/files/patch-aa
@@ -1,18 +1,21 @@
---- Makefile.orig Thu Apr 6 17:23:27 2000
-+++ Makefile Wed Oct 10 16:59:49 2001
-@@ -1,7 +1,12 @@
-+PREFIX = /usr/local
-+CXXFLAGS += -I${PREFIX}/include
-+LDFLAGS += -L${PREFIX}/lib
-+
- all: id3v2
+--- Makefile.orig Tue Apr 16 04:35:31 2002
++++ Makefile Sun Dec 22 03:51:30 2002
+@@ -1,10 +1,9 @@
+-all: id3v2
++CC= c++
++PROG= id3v2
++SRCS= id3v2.cpp list.cpp convert.cpp
++CXXFLAGS+= -I${DESTDIR}${PREFIX}/include
++LDADD+= -L${DESTDIR}${PREFIX}/lib -lid3 -lz -lgnugetopt
++DPADD+= ${LIBZ}
++DPADD+= ${DESTDIR}${PREFIX}/lib/libid3.a
-id3v2: Makefile convert.cpp list.cpp id3v2.cpp convert.cpp
-- g++ -lid3 -g -o id3v2 id3v2.cpp list.cpp convert.cpp
-+id3v2: convert.o list.o id3v2.o
-+ g++ ${LDFLAGS} -lid3 -lz -lgnugetopt -o $@ convert.o list.o id3v2.o
-
- install: all
+- g++ -lz -lid3 -g -o id3v2 id3v2.cpp list.cpp convert.cpp
+-
+-install: all
- cp id3v2 /usr/local/bin/
-+ install -c -s id3v2 ${PREFIX}/bin/id3v2
-+ nroff -man id3v2.1 > ${PREFIX}/man/man1/id3v2.1
+-
+-clean:
+- rm -f id3v2 core
++.include <bsd.prog.mk>
diff --git a/audio/id3v2/files/patch-ab b/audio/id3v2/files/patch-ab
deleted file mode 100644
index ac1941e3ffa9..000000000000
--- a/audio/id3v2/files/patch-ab
+++ /dev/null
@@ -1,74 +0,0 @@
---- convert.cpp~ Fri Apr 7 14:11:22 2000
-+++ convert.cpp Wed Oct 10 15:50:16 2001
-@@ -14,22 +14,22 @@
- cout << argv[nIndex] << "\"...";
-
- myTag.Clear();
-- myTag.Link(argv[nIndex]);
-+ myTag.Link(argv[nIndex], ID3TT_ALL);
-
- luint nTags;
- switch(whichTags)
- {
- case 1:
-- nTags = myTag.Strip(V1_TAG);
-+ nTags = myTag.Strip(ID3TT_ID3V1);
- cout << "id3v1 ";
- break;
- case 2:
-- nTags = myTag.Strip(V2_TAG);
-+ nTags = myTag.Strip(ID3TT_ID3V2);
- cout << "id3v2 ";
- break;
- case 0:
- default:
-- nTags = myTag.Strip(BOTH_ID3_TAGS);
-+ nTags = myTag.Strip(ID3TT_ID3);
- cout << "id3v1 and v2 ";
- }
-
-@@ -61,11 +61,11 @@
- cout << argv[nIndex] << "...";
-
- myTag.Clear();
-- myTag.Link(argv[nIndex]);
-+ myTag.Link(argv[nIndex], ID3TT_ALL);
-
- luint nTags;
-
-- nTags = myTag.Update(V2_TAG);
-+ nTags = myTag.Update(ID3TT_ID3V2);
- cout << " converted ";
- cout << endl;
- }
---- id3v2.cpp~ Sat Apr 22 13:46:44 2000
-+++ id3v2.cpp Wed Oct 10 15:52:09 2001
-@@ -291,7 +291,7 @@
- // cout << "Tagging " << argv[nIndex] << ": ";
-
- // fix me - not checking to see if we can link to it
-- myTag.Link(argv[nIndex], false, false);
-+ myTag.Link(argv[nIndex], ID3TT_ID3V2);
-
- // loop thru the frames we need to add/modify
- for(ii = 0; ii < frameCounter; ii++)
-@@ -557,7 +557,7 @@
- }
- } // steping thru frames
-
-- luint nTags = myTag.Update(V2_TAG);
-+ luint nTags = myTag.Update(ID3TT_ID3V2);
-
- }
- catch(ID3_Error err)
---- list.cpp~ Sat Apr 22 13:47:43 2000
-+++ list.cpp Wed Oct 10 15:52:37 2001
-@@ -353,7 +353,7 @@
-
- if(!PrintID3v1Tag(argv[nIndex]))
- tags = true;
-- myTag.Link(argv[nIndex], false, false);
-+ myTag.Link(argv[nIndex], ID3TT_ID3V2);
- if(!PrintInformation(argv[nIndex],myTag))
- tags = true;
- if(!tags)
diff --git a/audio/id3v2/files/patch-ac b/audio/id3v2/files/patch-ac
deleted file mode 100644
index eaf32ce76626..000000000000
--- a/audio/id3v2/files/patch-ac
+++ /dev/null
@@ -1,77 +0,0 @@
---- /dev/null Wed Oct 10 15:39:32 2001
-+++ id3v2.1 Mon Dec 11 00:53:03 2000
-@@ -0,0 +1,74 @@
-+.TH ID3V2 1 "May 2000" "" "User Command"
-+.SH NAME
-+id3v2 \- Adds/Modifies/Removes/Views id3v2 tags, converts/lists id3v1 tags
-+.SH SYNOPSIS
-+.B id3v2
-+.RB [
-+.I OPTION
-+.RB ]
-+...
-+.RB [
-+.I FILE
-+.RB ]
-+...
-+.br
-+.SH OPTIONS
-+.TP
-+.B \-h, \-\-help
-+Display help and exit
-+.TP
-+.B \-f, \-\-list\-frames
-+Display all possible frames for id3v2
-+.TP
-+.B \-L, \-\-list\-genres
-+Lists all id3v1 genres
-+.TP
-+.B \-v, \-\-version
-+Display version information and exit
-+.TP
-+.B \-l, \-\-list
-+Lists the tag(s) on the file(s)
-+.TP
-+.B \-R, \-\-list-rfc822
-+Lists using an rfc822\-style format for output
-+.TP
-+.B \-d, \-\-delete\-v2
-+Deletes id3v2 tags
-+.TP
-+.B \-s, \-\-delete\-v1
-+Deletes id3v1 tags
-+.TP
-+.B \-D, \-\-delete\-all
-+ Deletes both id3v1 and id3v2 tags
-+.TP
-+.B \-C, \-\-convert
-+ Converts id3v1 tag to id3v2
-+.TP
-+.B \-a, \-\-artist ARTIST
-+Set the artist information
-+.TP
-+.B \-A, \-\-album ALBUM
-+Set the album title information
-+.TP
-+.B \-t, \-\-song SONG
-+Set the song title information
-+.TP
-+.B \-c, \-\-comment DESCRIPTION:COMMENT
-+Set the comment information
-+.TP
-+.B \-g, \-\-genre num
-+Set the genre number
-+.TP
-+.B \-y, \-\-year num
-+Set the year
-+.TP
-+.B \-T, \-\-track num/num
-+Set the track number/(optional) total tracks
-+
-+.SH SEE ALSO
-+id3tag(1), id3info(1), id3convert(1)
-+.SH AUTHOR
-+.B id3v2
-+is by myers <icepick@users.sourceforge.net> with major portions used from id3lib
-+examples. Manual page written for Debian GNU/Linux by Robert Woodcock
-+<rcw@debian.org>.