aboutsummaryrefslogtreecommitdiffstats
path: root/audio/jack/Makefile
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-03-10 04:27:51 +0800
committerarved <arved@FreeBSD.org>2004-03-10 04:27:51 +0800
commitcaa79cb0bc29c516505ca3857551a8428783c1c0 (patch)
tree14b5463873a9054321559dfa6d47933584834816 /audio/jack/Makefile
parentca063683db8052b687299623c8c8adefa736b531 (diff)
downloadfreebsd-ports-gnome-caa79cb0bc29c516505ca3857551a8428783c1c0.tar.gz
freebsd-ports-gnome-caa79cb0bc29c516505ca3857551a8428783c1c0.tar.zst
freebsd-ports-gnome-caa79cb0bc29c516505ca3857551a8428783c1c0.zip
Add JACK an audio server
Requested by: epilogue@allstream.net
Diffstat (limited to 'audio/jack/Makefile')
-rw-r--r--audio/jack/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
new file mode 100644
index 000000000000..6ab2ed6b247c
--- /dev/null
+++ b/audio/jack/Makefile
@@ -0,0 +1,40 @@
+# New ports collection Makefile for: jackit
+# Date created: 14 May 2002
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= jackit
+PORTVERSION= 0.94.0
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= jackit
+DISTNAME= jack-audio-connection-kit-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= JACK is a low-latency audio server
+
+LIB_DEPENDS= portaudio.0:${PORTSDIR}/audio/portaudio \
+ sndfile.1:${PORTSDIR}/audio/libsndfile
+
+CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}" LDFLAGS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
+GNU_CONFIGURE= yes
+USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
+USE_GNOME= pkgconfig gnometarget gnomehack
+
+MAN1= jackd.1 jackstart.1
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS}," \
+ ${WRKSRC}/configure ${WRKSRC}/libjack/Makefile.in \
+ ${WRKSRC}/jackd/Makefile.in \
+ ${WRKSRC}/example-clients/Makefile.in
+ ${REINPLACE_CMD} -e "s,-lrt,," ${WRKSRC}/libjack/Makefile.in \
+ ${WRKSRC}/jackd/Makefile.in \
+ ${WRKSRC}/example-clients/Makefile.in
+ ${REINPLACE_CMD} -e "s,-ldl,," ${WRKSRC}/jackd/Makefile.in \
+ ${WRKSRC}/example-clients/Makefile.in
+
+.include <bsd.port.mk>