aboutsummaryrefslogtreecommitdiffstats
path: root/audio/jack
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2006-12-21 21:23:33 +0800
committerlofi <lofi@FreeBSD.org>2006-12-21 21:23:33 +0800
commitd1d5159a4a4820d5918bb147815cb2857653e8d4 (patch)
treee0880ed6b727b9864901ad60092343adac2ecb1d /audio/jack
parentafcc2427a2a988bc57c4ad5dd9ff0edddad9007e (diff)
downloadfreebsd-ports-gnome-d1d5159a4a4820d5918bb147815cb2857653e8d4.tar.gz
freebsd-ports-gnome-d1d5159a4a4820d5918bb147815cb2857653e8d4.tar.zst
freebsd-ports-gnome-d1d5159a4a4820d5918bb147815cb2857653e8d4.zip
o/` One more time, we're gonna fix four-ehehex, oh yeah, all right o/`
PR: ports/106982 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'audio/jack')
-rw-r--r--audio/jack/Makefile9
-rw-r--r--audio/jack/files/patch-example-clients_lsp.c14
2 files changed, 19 insertions, 4 deletions
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
index 8ff82f2f039d..f5aff9f0a242 100644
--- a/audio/jack/Makefile
+++ b/audio/jack/Makefile
@@ -48,6 +48,11 @@ CONFIGURE_ENV+= ac_cv_prog_HAVE_DOXYGEN="false"
PLIST_SUB+= DOCS="@comment "
.endif
+.if ${OSVERSION} < 500000
+CONFIGURE_ENV+= ac_cv_func_clock_gettime=no
+CFLAGS+= -Duintmax_t=uintptr_t
+.endif
+
.if (${OSVERSION} > 500000 ) && (${OSVERSION} < 502102 )
BROKEN= Does not compile
.endif
@@ -81,8 +86,4 @@ post-patch:
post-build:
@${RM} -f ${WRKSRC}/doc/reference/html/dir__2F*
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile on 4.x
-.endif
-
.include <bsd.port.post.mk>
diff --git a/audio/jack/files/patch-example-clients_lsp.c b/audio/jack/files/patch-example-clients_lsp.c
new file mode 100644
index 000000000000..43162c3a1e0f
--- /dev/null
+++ b/audio/jack/files/patch-example-clients_lsp.c
@@ -0,0 +1,14 @@
+--- example-clients/lsp.c.orig Fri May 26 11:45:08 2006
++++ example-clients/lsp.c Thu Dec 7 16:58:45 2006
+@@ -120,9 +120,9 @@
+ ports = jack_get_ports (client, NULL, NULL, 0);
+
+ for (i = 0; ports[i]; ++i) {
+- printf ("%s\n", ports[i]);
+-
+ jack_port_t *port = jack_port_by_name (client, ports[i]);
++
++ printf ("%s\n", ports[i]);
+
+ if (show_con) {
+ if ((connections = jack_port_get_all_connections (client, jack_port_by_name(client, ports[i]))) != 0) {