aboutsummaryrefslogtreecommitdiffstats
path: root/audio/jack
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-03-10 04:27:51 +0800
committerarved <arved@FreeBSD.org>2004-03-10 04:27:51 +0800
commitcaa79cb0bc29c516505ca3857551a8428783c1c0 (patch)
tree14b5463873a9054321559dfa6d47933584834816 /audio/jack
parentca063683db8052b687299623c8c8adefa736b531 (diff)
downloadfreebsd-ports-gnome-caa79cb0bc29c516505ca3857551a8428783c1c0.tar.gz
freebsd-ports-gnome-caa79cb0bc29c516505ca3857551a8428783c1c0.tar.zst
freebsd-ports-gnome-caa79cb0bc29c516505ca3857551a8428783c1c0.zip
Add JACK an audio server
Requested by: epilogue@allstream.net
Diffstat (limited to 'audio/jack')
-rw-r--r--audio/jack/Makefile40
-rw-r--r--audio/jack/distinfo2
-rw-r--r--audio/jack/files/patch-client.c57
-rw-r--r--audio/jack/files/patch-driver.c31
-rw-r--r--audio/jack/files/patch-engine.c25
-rw-r--r--audio/jack/files/patch-jack.h17
-rw-r--r--audio/jack/files/patch-ringbuffer.c10
-rw-r--r--audio/jack/pkg-descr13
-rw-r--r--audio/jack/pkg-plist33
9 files changed, 228 insertions, 0 deletions
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
new file mode 100644
index 000000000000..6ab2ed6b247c
--- /dev/null
+++ b/audio/jack/Makefile
@@ -0,0 +1,40 @@
+# New ports collection Makefile for: jackit
+# Date created: 14 May 2002
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= jackit
+PORTVERSION= 0.94.0
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= jackit
+DISTNAME= jack-audio-connection-kit-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= JACK is a low-latency audio server
+
+LIB_DEPENDS= portaudio.0:${PORTSDIR}/audio/portaudio \
+ sndfile.1:${PORTSDIR}/audio/libsndfile
+
+CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}" LDFLAGS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
+GNU_CONFIGURE= yes
+USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
+USE_GNOME= pkgconfig gnometarget gnomehack
+
+MAN1= jackd.1 jackstart.1
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS}," \
+ ${WRKSRC}/configure ${WRKSRC}/libjack/Makefile.in \
+ ${WRKSRC}/jackd/Makefile.in \
+ ${WRKSRC}/example-clients/Makefile.in
+ ${REINPLACE_CMD} -e "s,-lrt,," ${WRKSRC}/libjack/Makefile.in \
+ ${WRKSRC}/jackd/Makefile.in \
+ ${WRKSRC}/example-clients/Makefile.in
+ ${REINPLACE_CMD} -e "s,-ldl,," ${WRKSRC}/jackd/Makefile.in \
+ ${WRKSRC}/example-clients/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/audio/jack/distinfo b/audio/jack/distinfo
new file mode 100644
index 000000000000..9ada027034ba
--- /dev/null
+++ b/audio/jack/distinfo
@@ -0,0 +1,2 @@
+MD5 (jack-audio-connection-kit-0.94.0.tar.gz) = 9c3d60f0ca73696ba5c479a3ee7db855
+SIZE (jack-audio-connection-kit-0.94.0.tar.gz) = 561277
diff --git a/audio/jack/files/patch-client.c b/audio/jack/files/patch-client.c
new file mode 100644
index 000000000000..18b68558a6f1
--- /dev/null
+++ b/audio/jack/files/patch-client.c
@@ -0,0 +1,57 @@
+--- libjack/client.c.orig Sun Jan 11 20:07:14 2004
++++ libjack/client.c Tue Mar 9 20:19:15 2004
+@@ -26,20 +26,23 @@
+ #else
+ #include <sys/poll.h>
+ #endif
+-
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
+ #include <pthread.h>
+ #include <errno.h>
+ #include <fcntl.h>
+-#include <sys/types.h>
++
+ #include <sys/ipc.h>
+ #include <sys/mman.h>
+
+ #include <stdarg.h>
+ #include <stdio.h>
++#if HAVE_STDINT_H
+ #include <stdint.h>
++#endif
+ #include <regex.h>
++#include <string.h>
+
+ #include <config.h>
+
+@@ -1152,8 +1155,12 @@
+ "thread (%s)", strerror (errno));
+ return -1;
+ }
+-
+-#if defined(__APPLE__) && defined(__POWERPC__)
++
++#ifdef __FreeBSD__
++#include <osreldate.h>
++#endif
++#if defined(__APPLE__) && defined(__POWERPC__) || (__FreeBSD_version < 501000)
++
+ // To be implemented
+ #else
+ if (mlockall (MCL_CURRENT | MCL_FUTURE) != 0) {
+@@ -1307,8 +1314,11 @@
+ * pages are actually mapped (more important for mlockall(2)
+ * usage in jack_start_thread())
+ */
+-
+-#if defined(__APPLE__) && defined(__POWERPC__)
++
++#ifdef __FreeBSD__
++#include <osreldate.h>
++#endif
++#if (defined(__APPLE__) && defined(__POWERPC__)) || (__FreeBSD_version < 501000)
+ /* a bigger stack makes the application crash... */
+ #define BIG_ENOUGH_STACK 10000
+ #else
diff --git a/audio/jack/files/patch-driver.c b/audio/jack/files/patch-driver.c
new file mode 100644
index 000000000000..15194d406eeb
--- /dev/null
+++ b/audio/jack/files/patch-driver.c
@@ -0,0 +1,31 @@
+--- libjack/driver.c.orig Thu Dec 11 00:50:40 2003
++++ libjack/driver.c Tue Mar 9 19:52:04 2004
+@@ -24,6 +24,7 @@
+ #include <stdarg.h>
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <sys/types.h>
+ #include <sys/mman.h>
+ #include <errno.h>
+
+@@ -105,6 +106,11 @@
+ return -1;
+ }
+
++#ifdef __FreeBSD__
++#include <osreldate.h>
++#endif
++#if (defined(__APPLE__) && defined(__POWERPC__)) || (__FreeBSD_version < 501000)
++#else
+ if (mlockall (MCL_CURRENT | MCL_FUTURE) != 0) {
+ jack_error ("cannot lock down memory for RT thread (%s)",
+ strerror (errno));
+@@ -112,7 +118,7 @@
+ return -1;
+ #endif /* ENSURE_MLOCK */
+ }
+-
++#endif
+ return 0;
+ }
+
diff --git a/audio/jack/files/patch-engine.c b/audio/jack/files/patch-engine.c
new file mode 100644
index 000000000000..1c6607fed22a
--- /dev/null
+++ b/audio/jack/files/patch-engine.c
@@ -0,0 +1,25 @@
+--- jackd/engine.c.orig Sun Jan 11 20:07:13 2004
++++ jackd/engine.c Tue Mar 9 19:43:47 2004
+@@ -36,7 +36,9 @@
+ #include <fcntl.h>
+ #include <stdio.h>
+ #include <stdarg.h>
++#ifdef HAVE_STDINT_H
+ #include <stdint.h>
++#endif
+ #include <dirent.h>
+ #include <sys/ipc.h>
+ #include <signal.h>
+@@ -2119,8 +2124,10 @@
+ strerror (errno));
+ return -1;
+ }
+-
+-#if defined(__APPLE__) && defined(__POWERPC__)
++#ifdef __FreeBSD__
++#include <osreldate.h>
++#endif
++#if (defined(__APPLE__) && defined(__POWERPC__)) || (__FreeBSD_version < 501000)
+ // To be implemented
+ #else
+ if (mlockall (MCL_CURRENT | MCL_FUTURE) != 0) {
diff --git a/audio/jack/files/patch-jack.h b/audio/jack/files/patch-jack.h
new file mode 100644
index 000000000000..74a2c0732793
--- /dev/null
+++ b/audio/jack/files/patch-jack.h
@@ -0,0 +1,17 @@
+--- jack/types.h.org Tue Mar 9 20:12:17 2004
++++ jack/types.h Tue Mar 9 20:12:22 2004
+@@ -22,6 +22,14 @@
+ #define __jack_types_h__
+
+ #include <inttypes.h>
++#ifndef PRIu32
++#define PRIi32 "i" /* int32_t */
++#define PRIu32 "u" /* uint32_t */
++#define PRIu64 "llu" /* uint64_t */
++#define SCNu64 "llu" /* uint64_t */
++#define PRId32 "d" /* int32_t */
++#define PRIx64 "llx" /* uint64_t */
++#endif
+
+ typedef char shm_name_t[32];
+ typedef int32_t jack_shmsize_t;
diff --git a/audio/jack/files/patch-ringbuffer.c b/audio/jack/files/patch-ringbuffer.c
new file mode 100644
index 000000000000..7e5bf885a72f
--- /dev/null
+++ b/audio/jack/files/patch-ringbuffer.c
@@ -0,0 +1,10 @@
+--- libjack/ringbuffer.c.orig Tue Mar 9 18:57:50 2004
++++ libjack/ringbuffer.c Tue Mar 9 18:58:07 2004
+@@ -22,6 +22,7 @@
+
+ #include <stdlib.h>
+ #include <string.h>
++#include <sys/types.h>
+ #include <sys/mman.h>
+ #include <jack/ringbuffer.h>
+
diff --git a/audio/jack/pkg-descr b/audio/jack/pkg-descr
new file mode 100644
index 000000000000..b00f451ed36b
--- /dev/null
+++ b/audio/jack/pkg-descr
@@ -0,0 +1,13 @@
+JACK is a low-latency audio server, written for POSIX conformant
+operating systems. It can connect a number of different applications
+to an audio device, as well as allowing them to share audio between
+themselves. Its clients can run in their own processes (ie. as normal
+applications), or can they can run within the JACK server (ie. as a
+"plugin").
+
+JACK was designed from the ground up for professional audio work, and
+its design focuses on two key areas: synchronous execution of all
+clients, and low latency operation.
+
+WWW: http://jackit.sourceforge.net/
+Author: Paul Davis
diff --git a/audio/jack/pkg-plist b/audio/jack/pkg-plist
new file mode 100644
index 000000000000..b72e85959e8b
--- /dev/null
+++ b/audio/jack/pkg-plist
@@ -0,0 +1,33 @@
+include/jack/jack.h
+include/jack/ringbuffer.h
+include/jack/timestamps.h
+include/jack/transport.h
+include/jack/types.h
+lib/libjack.so.0
+lib/libjack.la
+bin/jackd
+lib/jack/jack_dummy.so
+lib/jack/jack_dummy.la
+lib/jack/jack_portaudio.so
+lib/jack/jack_portaudio.la
+bin/jack_load
+bin/jack_unload
+bin/jack_simple_client
+bin/jack_monitor_client
+bin/jack_impulse_grabber
+bin/jack_connect
+bin/jack_disconnect
+bin/jack_metro
+bin/jack_showtime
+bin/jack_bufsize
+bin/jack_lsp
+bin/jack_freewheel
+bin/jackrec
+bin/jack_transport
+lib/jack/inprocess.so
+lib/jack/inprocess.la
+lib/jack/intime.so
+lib/jack/intime.la
+libdata/pkgconfig/jack.pc
+@dirrm include/jack
+@dirrm lib/jack