aboutsummaryrefslogtreecommitdiffstats
path: root/audio/juk
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2007-04-15 17:35:14 +0800
committerlofi <lofi@FreeBSD.org>2007-04-15 17:35:14 +0800
commit01ec93d404f45202e93f9f44510cf2226d4b5af4 (patch)
tree53d74a743354629379c2b1f90c757c5b091463c3 /audio/juk
parent03d7a128cc58831f687822c8c830841007700726 (diff)
downloadfreebsd-ports-gnome-01ec93d404f45202e93f9f44510cf2226d4b5af4.tar.gz
freebsd-ports-gnome-01ec93d404f45202e93f9f44510cf2226d4b5af4.tar.zst
freebsd-ports-gnome-01ec93d404f45202e93f9f44510cf2226d4b5af4.zip
Depend on current libtunepimp.
PR: ports/111440 Submitted by: Li-Wen Hsu <lwhsu@FreeBSD.org>
Diffstat (limited to 'audio/juk')
-rw-r--r--audio/juk/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/audio/juk/Makefile b/audio/juk/Makefile
index abddc4c304ff..26b21f16b261 100644
--- a/audio/juk/Makefile
+++ b/audio/juk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= juk
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
@@ -20,7 +21,7 @@ COMMENT= KDE audio player
LIB_DEPENDS= akode:${PORTSDIR}/audio/akode \
musicbrainz:${PORTSDIR}/audio/libmusicbrainz \
tag:${PORTSDIR}/audio/taglib \
- tunepimp-0.4.3:${PORTSDIR}/audio/libtunepimp-old
+ tunepimp:${PORTSDIR}/audio/libtunepimp
CONFLICTS= kdemultimedia-3.3*
@@ -30,12 +31,11 @@ USE_KDELIBS_VER=3
PREFIX= ${KDE_PREFIX}
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/kdemultimedia-${PORTVERSION}
USE_LDCONFIG= yes
-CONFIGURE_ARGS+=CFLAGS=-I${LOCALBASE}/include/tunepimp-0.4 \
- LDFLAGS=-L${LOCALBASE}/lib/tunepimp-0.4
+INSTALLS_ICONS= yes
.include <bsd.port.pre.mk>
@@ -64,9 +64,6 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|LIBS="-ltunepimp $$LIBS"|LIBS="-ltunepimp -liconv $$LIBS"|g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-ltunepimp|-ltunepimp-0.4|g' \
- -e 's|<tunepimp/tp_c.h>|<tunepimp-0.4/tunepimp/tp_c.h>|g' \
- ${WRKSRC}/configure ${WRKSRC}/juk/ktrm.cpp ${WRKSRC}/juk/Makefile.in
do-build:
cd ${WRKSRC}/arts/runtime && ${SETENV} ${MAKE_ENV} ${GMAKE}