aboutsummaryrefslogtreecommitdiffstats
path: root/audio/kmpg/files
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1998-06-12 16:06:02 +0800
committertg <tg@FreeBSD.org>1998-06-12 16:06:02 +0800
commit932392a2802e00288e6823c4da08ef6fa70c84fe (patch)
treef8e22a98398b74a6317739040f6b128446ee6586 /audio/kmpg/files
parent1db53c0d3262603ac00b508dbfc57fe131f160e8 (diff)
downloadfreebsd-ports-gnome-932392a2802e00288e6823c4da08ef6fa70c84fe.tar.gz
freebsd-ports-gnome-932392a2802e00288e6823c4da08ef6fa70c84fe.tar.zst
freebsd-ports-gnome-932392a2802e00288e6823c4da08ef6fa70c84fe.zip
New port kmpg, an MPEG audio player for KDE.
PR: 6727 Submitted by: Hans Petter Bieker <hanspb@persbraten.vgs.no>
Diffstat (limited to 'audio/kmpg/files')
-rw-r--r--audio/kmpg/files/patch-aa38
-rw-r--r--audio/kmpg/files/patch-ab22
-rw-r--r--audio/kmpg/files/patch-ac11
-rw-r--r--audio/kmpg/files/patch-af12
-rw-r--r--audio/kmpg/files/patch-ag15
-rw-r--r--audio/kmpg/files/patch-ah15
6 files changed, 113 insertions, 0 deletions
diff --git a/audio/kmpg/files/patch-aa b/audio/kmpg/files/patch-aa
new file mode 100644
index 000000000000..c6d808bd41bb
--- /dev/null
+++ b/audio/kmpg/files/patch-aa
@@ -0,0 +1,38 @@
+--- Makefile.orig Wed May 6 23:35:22 1998
++++ Makefile Sat May 23 17:02:25 1998
+@@ -1,18 +1,18 @@
+ ####### Kmpg Makefile
+
+-INCDIR = -I$(QTDIR)/include -I$(KDEDIR)/include
++INCDIR = -I$(X11BASE)/include/X11/qt -I$(X11BASE)/include -I$(LOCALBASE)/include
+ CFLAGS = -O6
+-LFLAGS = -L$(QTDIR)/lib -lqt -L/usr/X11R6/lib -L$(KDEDIR)/lib -lXext -lX11 -lkdecore -lkdeui -lm -lg++
++LFLAGS = -L$(X11BASE)/lib -L$(LOCALBASE)/lib -lqt -lXext -lX11 -lkdecore -lkdeui -lm -lg++ -lcompat
+ CC = g++
+-MOC = $(QTDIR)/bin/moc
++MOC = $(X11BASE)/bin/moc
+
+ ############# Install ##############
+
+-INSTALL = install -m 0755 -s
+-INSTALL_SHELL = install -m 0755
+-INSTALL_DATA = install -m 0644
+-INSTALL_DIR = install -d -m 0755
+-INSTALL_DIR_PRIVATE = install -d -m 0700
++INSTALL = install -c -m 0555 -s -o bin -g bin
++INSTALL_SHELL = install -c -m 0555 -o bin -g bin
++INSTALL_DATA = install -c -m 0444 -o bin -g bin
++INSTALL_DIR = install -c -d -m 0755 -o root -g wheel
++INSTALL_DIR_PRIVATE = install -c -d -m 0700 -o root -g wheel
+
+ prefix = $(KDEDIR)
+ BINDIR = $(prefix)/bin
+@@ -52,7 +52,7 @@
+ $(CC) $(OBJECTS) $(OBJMETA) -o $(TARGET) $(LFLAGS)
+
+ library:
+- cd lib; make linux; cd ..
++ cd lib; make freebsd; cd ..
+
+ depend:
+ @makedepend $(INCDIR) $(SOURCES) 2> /dev/null
diff --git a/audio/kmpg/files/patch-ab b/audio/kmpg/files/patch-ab
new file mode 100644
index 000000000000..e9ddd1c86c23
--- /dev/null
+++ b/audio/kmpg/files/patch-ab
@@ -0,0 +1,22 @@
+--- lib/mpg123.c.orig Thu May 14 18:26:41 1998
++++ lib/mpg123.c Thu May 14 18:27:28 1998
+@@ -1176,7 +1176,7 @@
+ /* return 1; */
+ }
+
+- while (frameNum < frame) // seek forward
++ while (frameNum < frame) /* seek forward */
+ {
+ if(fr.lay == 3)
+ set_pointer(512);
+@@ -1263,8 +1263,8 @@
+
+ MPEGclose();
+ usebuffer = _prefs->buffersize;
+- MPEGplayfile(name); // this calls MPEGinit();
+- MPEGseek( pos );// find old frame and keep on playing
++ MPEGplayfile(name); /* this calls MPEGinit(); */
++ MPEGseek( pos );/* find old frame and keep on playing */
+ }
+ }
+
diff --git a/audio/kmpg/files/patch-ac b/audio/kmpg/files/patch-ac
new file mode 100644
index 000000000000..f2207f6355e4
--- /dev/null
+++ b/audio/kmpg/files/patch-ac
@@ -0,0 +1,11 @@
+--- lib/Makefile.orig Thu May 14 18:29:32 1998
++++ lib/Makefile Thu May 14 18:29:48 1998
+@@ -208,7 +208,7 @@
+ mpg123.a: player.o mpg123_2.o common.o $(OBJECTS) decode_2to1.o decode_4to1.o \
+ tabinit.o audio.o layer1.o layer2.o layer3.o buffer.o \
+ getlopt.o httpget.o xfermem.o equalizer.o Makefile
+- ar -rs mpg123.a player.o mpg123_2.o tabinit.o common.o layer1.o \
++ ar -r mpg123.a player.o mpg123_2.o tabinit.o common.o layer1.o \
+ layer2.o layer3.o audio.o buffer.o decode_2to1.o equalizer.o \
+ decode_4to1.o getlopt.o httpget.o xfermem.o $(OBJECTS)
+
diff --git a/audio/kmpg/files/patch-af b/audio/kmpg/files/patch-af
new file mode 100644
index 000000000000..457f0dc690a7
--- /dev/null
+++ b/audio/kmpg/files/patch-af
@@ -0,0 +1,12 @@
+--- khelp.h.orig Thu May 14 19:18:49 1998
++++ khelp.h Thu May 14 19:19:35 1998
+@@ -11,7 +11,9 @@
+ #include <sys/types.h>
+ #include <sys/ipc.h>
+ #include <sys/msg.h>
++#include <sys/msgbuf.h>
+
++long mtype;
+
+ class KHelpMsg : protected msgbuf
+ {
diff --git a/audio/kmpg/files/patch-ag b/audio/kmpg/files/patch-ag
new file mode 100644
index 000000000000..bbfde2a7a915
--- /dev/null
+++ b/audio/kmpg/files/patch-ag
@@ -0,0 +1,15 @@
+--- kmpg.h.orig Thu May 14 19:20:37 1998
++++ kmpg.h Thu May 14 19:20:55 1998
+@@ -24,10 +24,10 @@
+ #include <signal.h>
+ #include <sys/utsname.h>
+ #include <unistd.h>
+-#if defined(_FreeBSD__) || defined(__NetBSD__)
++#if defined(__FreeBSD__) || defined(__NetBSD__)
+ #else
+ #include <mntent.h>
+-#include <sys/soundcard.h>
++#include <machine/soundcard.h>
+ #endif
+ #include <sys/types.h>
+ #include <sys/stat.h>
diff --git a/audio/kmpg/files/patch-ah b/audio/kmpg/files/patch-ah
new file mode 100644
index 000000000000..2a9fce07f480
--- /dev/null
+++ b/audio/kmpg/files/patch-ah
@@ -0,0 +1,15 @@
+--- playlist.h.orig Thu May 14 19:22:14 1998
++++ playlist.h Thu May 14 19:22:24 1998
+@@ -10,10 +10,10 @@
+ #include <signal.h>
+ #include <sys/utsname.h>
+ #include <unistd.h>
+-#if defined(_FreeBSD__) || defined(__NetBSD__)
++#if defined(__FreeBSD__) || defined(__NetBSD__)
+ #else
+ #include <mntent.h>
+-#include <sys/soundcard.h>
++#include <machine/soundcard.h>
+ #endif
+ #include <sys/types.h>
+ #include <sys/stat.h>