aboutsummaryrefslogtreecommitdiffstats
path: root/audio/lame
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2002-09-30 23:24:53 +0800
committermi <mi@FreeBSD.org>2002-09-30 23:24:53 +0800
commit86b40107e021751dc7a9dd3160d7ec2547edd340 (patch)
tree9d1d87841aded7d12551d91d9b6fcc6fefd062d5 /audio/lame
parent3752b7a1cf88f0e80699830c596cd929af8ead55 (diff)
downloadfreebsd-ports-gnome-86b40107e021751dc7a9dd3160d7ec2547edd340.tar.gz
freebsd-ports-gnome-86b40107e021751dc7a9dd3160d7ec2547edd340.tar.zst
freebsd-ports-gnome-86b40107e021751dc7a9dd3160d7ec2547edd340.zip
Fix the bugs and buglets which were causing warnings on -stable and
error(s) on -current. Approved by: knu (portmgr) with a very minor deviation
Diffstat (limited to 'audio/lame')
-rw-r--r--audio/lame/Makefile1
-rw-r--r--audio/lame/files/patch-maxpath8
-rw-r--r--audio/lame/files/patch-sloppy23
3 files changed, 32 insertions, 0 deletions
diff --git a/audio/lame/Makefile b/audio/lame/Makefile
index 8d22c7f5c0f5..c3b8ca0731e1 100644
--- a/audio/lame/Makefile
+++ b/audio/lame/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lame
PORTVERSION= 3.91
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://lame.sourceforge.net/pub/
diff --git a/audio/lame/files/patch-maxpath b/audio/lame/files/patch-maxpath
new file mode 100644
index 000000000000..2a1be234cc32
--- /dev/null
+++ b/audio/lame/files/patch-maxpath
@@ -0,0 +1,8 @@
+--- frontend/main.h Mon Oct 29 17:00:15 2001
++++ frontend/main.h Fri Sep 27 18:15:33 2002
+@@ -25,3 +25,3 @@
+
+-#define MAX_NAME_SIZE 1000
++#include <sys/param.h>
++#define MAX_NAME_SIZE MAXPATHLEN
+-
diff --git a/audio/lame/files/patch-sloppy b/audio/lame/files/patch-sloppy
new file mode 100644
index 000000000000..522a4e5390ee
--- /dev/null
+++ b/audio/lame/files/patch-sloppy
@@ -0,0 +1,23 @@
+--- frontend/rtp.h Tue Dec 19 02:43:25 2000
++++ frontend/rtp.h Fri Sep 27 18:26:42 2002
+@@ -28,3 +28,3 @@
+
+-#ifdef 0
++#if 0
+ int rtp_send (
+--- frontend/mp3rtp.c Fri Jun 8 17:29:34 2001
++++ frontend/mp3rtp.c Fri Sep 27 18:29:04 2002
+@@ -48,6 +48,4 @@
+ #endif
+
+-#define MAX_NAME_SIZE 2048 /* current value of Linux */
+-
+ /*
+ * Encode (via LAME) to mp3 with RTP streaming of the output.
+@@ -89,5 +87,5 @@
+
+
+-unsigned maxvalue ( short int Buffer [2] [1152] )
++unsigned maxvalue ( int Buffer [2] [1152] )
+ {
+ int max = 0;