aboutsummaryrefslogtreecommitdiffstats
path: root/audio/last.fm
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-07 14:45:39 +0800
committerbapt <bapt@FreeBSD.org>2013-05-07 14:45:39 +0800
commite286866d1ad7053987b8699d1355aae9063f71f0 (patch)
tree0f5dd8fc023d3dda43cf61eccf2f86d7e2dd7ca4 /audio/last.fm
parent93d0bd4c8ef9cdadabad93879a9ec167057d4a58 (diff)
downloadfreebsd-ports-gnome-e286866d1ad7053987b8699d1355aae9063f71f0.tar.gz
freebsd-ports-gnome-e286866d1ad7053987b8699d1355aae9063f71f0.tar.zst
freebsd-ports-gnome-e286866d1ad7053987b8699d1355aae9063f71f0.zip
Use shebangfix
Diffstat (limited to 'audio/last.fm')
-rw-r--r--audio/last.fm/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/audio/last.fm/Makefile b/audio/last.fm/Makefile
index 4ab826789625..c8452c6e7d8f 100644
--- a/audio/last.fm/Makefile
+++ b/audio/last.fm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: last.fm
-# Date created: February 5th, 2007
-# Whom: Michael Nottebrock <lofi@freebsd.org>
-#
+# Created by: Michael Nottebrock <lofi@freebsd.org>
# $FreeBSD$
-#
PORTNAME= last.fm
PORTVERSION= 1.5.4.26862
@@ -27,12 +23,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
SUB_FILES= pkg-install pkg-deinstall
+USES= shebangfix
USE_BZIP2= yes
USE_QT4= gui imageformats_run moc_build network qmake_build rcc_build \
sql uic_build xml
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
USE_DOS2UNIX= *.h
+SHEBANG_FILES= dist/tarball_files/configure
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -44,8 +42,7 @@ USE_GCC=4.2+
post-patch:
${CP} ${WRKSRC}/dist/tarball_files/configure ${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's|/bin/bash|/${LOCALBASE}/bin/bash|g' \
- -E -e 's|(.*"CONFIG-=debug")|\1 ${QMAKEFLAGS}|g' \
+ ${REINPLACE_CMD} -E -e 's|(.*"CONFIG-=debug")|\1 ${QMAKEFLAGS}|g' \
-e 's|function header|header()|g' \
-e 's|function middle|middle()|g' \
-e 's|-pthread|-pthread -R/usr/local/share/last.fm|g' \