aboutsummaryrefslogtreecommitdiffstats
path: root/audio/liba52
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2006-02-23 18:40:44 +0800
committerade <ade@FreeBSD.org>2006-02-23 18:40:44 +0800
commitda880765886f48c0ac8fd253e5601d04ea853215 (patch)
tree55155f50e8a40ea2e2a16e2331e8cbb919b7d04f /audio/liba52
parentba4beb1ea11e6147a9b30969be42685d1c709e56 (diff)
downloadfreebsd-ports-gnome-da880765886f48c0ac8fd253e5601d04ea853215.tar.gz
freebsd-ports-gnome-da880765886f48c0ac8fd253e5601d04ea853215.tar.zst
freebsd-ports-gnome-da880765886f48c0ac8fd253e5601d04ea853215.zip
Conversion to a single libtool environment.
Approved by: portmgr (kris)
Diffstat (limited to 'audio/liba52')
-rw-r--r--audio/liba52/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/audio/liba52/Makefile b/audio/liba52/Makefile
index 1831debcf532..1b6de646dbbb 100644
--- a/audio/liba52/Makefile
+++ b/audio/liba52/Makefile
@@ -19,7 +19,6 @@ USE_GMAKE= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-oss --enable-shared
-USE_AUTOTOOLS= libtool:13
INSTALLS_SHLIB= yes
.if !defined(WITHOUT_DJBFFT) && !defined(PACKAGE_BUILDING)
@@ -31,6 +30,12 @@ CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
CONFIGURE_ARGS+= --enable-djbfft
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+CFLAGS+= -fPIC
+.endif
+
MAN1= a52dec.1 extract_a52.1
HEADER_FILES= liba52/a52_internal.h
@@ -58,9 +63,6 @@ post-patch:
@${REINPLACE_CMD} -E -e 's|(fftc4.h)|djbfft/\1|' ${WRKSRC}/liba52/imdct.c
.endif
-post-configure:
- @${LN} -sf ${LIBTOOL} ${WRKSRC}/libtool
-
post-install:
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -70,4 +72,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/include/a52dec
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>