aboutsummaryrefslogtreecommitdiffstats
path: root/audio/libamrnb/files
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-07-15 05:33:04 +0800
committermiwi <miwi@FreeBSD.org>2007-07-15 05:33:04 +0800
commitb08ed306811ec6249cef0798766c80a9291b7b50 (patch)
tree22a7803b044a4a9cb7b8996f295d5d46117ccac0 /audio/libamrnb/files
parent5ed228954e22a89229ea8f168185a283d6531766 (diff)
downloadfreebsd-ports-gnome-b08ed306811ec6249cef0798766c80a9291b7b50.tar.gz
freebsd-ports-gnome-b08ed306811ec6249cef0798766c80a9291b7b50.tar.zst
freebsd-ports-gnome-b08ed306811ec6249cef0798766c80a9291b7b50.zip
- Fix Build
- Makefile cleanup PR: 113627 Submitted by: pointyhat via kris/pav Thanks to: Fredrik Lindberg, linimon Reviewed by: sat
Diffstat (limited to 'audio/libamrnb/files')
-rw-r--r--audio/libamrnb/files/patch-Makefile.in24
-rw-r--r--audio/libamrnb/files/patch-configure15
-rw-r--r--audio/libamrnb/files/patch-prepare_sources.sh31
-rw-r--r--audio/libamrnb/files/pkg-message.in17
4 files changed, 87 insertions, 0 deletions
diff --git a/audio/libamrnb/files/patch-Makefile.in b/audio/libamrnb/files/patch-Makefile.in
new file mode 100644
index 000000000000..230e40eee64c
--- /dev/null
+++ b/audio/libamrnb/files/patch-Makefile.in
@@ -0,0 +1,24 @@
+--- Makefile.in.orig Sat May 26 04:34:54 2007
++++ Makefile.in Sun Jul 15 00:48:06 2007
+@@ -250,7 +250,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ EXTRA_DIST = amrnb-any-cflags.patch amrnb-intsizes.patch amrnb-strict-aliasing.patch prepare_sources.sh amrnb.spec
+-DISTCLEANFILES = 26104-610.zip 26104-610.doc 26104-610_ANSI_C_source_code.zip
++DISTCLEANFILES = 26104-610.doc 26104-610_ANSI_C_source_code.zip
+ lib_LTLIBRARIES = \
+ libamrnb.la
+
+@@ -922,10 +922,10 @@
+ chmod og-w 26104-610.doc
+
+ 26104-610.zip:
+- $(WGET) -N http://www.3gpp.org/ftp/Specs/archive/26_series/26.104/26104-610.zip
++ test -e 26104-610.zip
+
+ extraclean:
+- rm -f $(distdir)/*.c $(distdir)/*.h $(distdir)/readme.txt $(distdir)/26104-610.zip $(distdir)/26104-610.doc $(distdir)/26104-610_ANSI_C_source_code.zip
++ rm -f $(distdir)/*.c $(distdir)/*.h $(distdir)/readme.txt $(distdir)/26104-610.doc $(distdir)/26104-610_ANSI_C_source_code.zip
+
+ # WARNING: These commands use internal automake command and may fail in future version.
+ extradist-gzip: distdir extraclean
diff --git a/audio/libamrnb/files/patch-configure b/audio/libamrnb/files/patch-configure
new file mode 100644
index 000000000000..4e6b0385f3e1
--- /dev/null
+++ b/audio/libamrnb/files/patch-configure
@@ -0,0 +1,15 @@
+--- configure.orig Fri Jun 22 12:43:20 2007
++++ configure Fri Jun 22 12:43:24 2007
+@@ -20338,12 +20338,6 @@
+ fi
+
+
+-if test x"$WGET" = x -a ! "(" -f "26104-610.zip" -o -f "sp_enc.c" ")" ; then
+- { { echo "$as_me:$LINENO: error: You need wget utility to download sources." >&5
+-echo "$as_me: error: You need wget utility to download sources." >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-
+ # Checks for libraries.
+ { echo "$as_me:$LINENO: checking for library containing sqrt" >&5
+ echo $ECHO_N "checking for library containing sqrt... $ECHO_C" >&6; }
diff --git a/audio/libamrnb/files/patch-prepare_sources.sh b/audio/libamrnb/files/patch-prepare_sources.sh
new file mode 100644
index 000000000000..cab31005100f
--- /dev/null
+++ b/audio/libamrnb/files/patch-prepare_sources.sh
@@ -0,0 +1,31 @@
+--- prepare_sources.sh.orig Wed Jun 6 23:52:12 2007
++++ prepare_sources.sh Sat Jul 14 23:35:53 2007
+@@ -1,10 +1,10 @@
+-#! /bin/bash
++#! /bin/sh
+
+ set -o errexit
+-trap "rm -rf c-code *.c *.h readme.txt *.new *.def *.all" ERR
++trap "rm -rf c-code *.c *.h readme.txt *.new *.def *.all" 0
+
+ if [ "$0" = prepare_sources.sh ] ; then
+- cd "$(if ! which 2>/dev/null prepare_sources.sh ; then echo . fi )"
++ cd "$(if ! which 2>/dev/null prepare_sources.sh ; then echo . ; fi )"
+ else
+ cd "${0%/*}"
+ fi
+@@ -23,7 +23,7 @@
+ patch <amrnb-strict-aliasing.patch
+ patch <amrnb-any-cflags.patch
+
+-for FILE in interf_{dec,enc}.{c,h} ; do
++for FILE in interf_dec.[ch] interf_enc.[ch] ; do
+ echo "modifying file $FILE"
+ if test $FILE = ${FILE%.h} ; then
+ ENDSTRING="^}"
+@@ -100,3 +100,5 @@
+ rm $FILE.def $FILE.all
+ done
+ done
++
++trap 0
diff --git a/audio/libamrnb/files/pkg-message.in b/audio/libamrnb/files/pkg-message.in
new file mode 100644
index 000000000000..eed7dd4140e8
--- /dev/null
+++ b/audio/libamrnb/files/pkg-message.in
@@ -0,0 +1,17 @@
+
+AMR codecs incorporate several patents, held by Ericsson,
+Universite de Sherbrooke (VoiceAge) and Nokia.
+VoiceAge claims to provide patent portfolio for AMR codecs. Depending on law in
+your country, manufacturers and developers may need to get a license.
+Because it is a shared library, you may need a special contract for each one
+application, which links against this library, directly or indirectly.
+
+* 3GPP policy on licensing and 3G Patent Platform:
+ http://www.3gpp.org/faq/faq_2005_2.htm#A3.1
+* Intellectual property in ETSI standards:
+ http://webapp.etsi.org/IPR/home.asp
+* On 3GPP legal issues:
+ http://www.3gpp.org/legal/legal.htm
+* On VoiceAge licensing:
+ http://www.voiceage.com/licensing.php
+