aboutsummaryrefslogtreecommitdiffstats
path: root/audio/libechonest/files
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2013-03-07 06:53:30 +0800
committernivit <nivit@FreeBSD.org>2013-03-07 06:53:30 +0800
commit4512f32171d6360db11bff33ef1b39c342f06206 (patch)
treebd706c1ac58156351453d8a7862d9c7a13e03cb1 /audio/libechonest/files
parent37e118320ce79da54db42d139b922ffbb578e84c (diff)
downloadfreebsd-ports-gnome-4512f32171d6360db11bff33ef1b39c342f06206.tar.gz
freebsd-ports-gnome-4512f32171d6360db11bff33ef1b39c342f06206.tar.zst
freebsd-ports-gnome-4512f32171d6360db11bff33ef1b39c342f06206.zip
libechonest is a collection of C++/Qt classes designed to make a developer's
life easy when trying to use the APIs provided by The Echo Nest. WWW: http://github.com/dschimdt/libechonest
Diffstat (limited to 'audio/libechonest/files')
-rw-r--r--audio/libechonest/files/patch-CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/audio/libechonest/files/patch-CMakeLists.txt b/audio/libechonest/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..cecdd917fe4c
--- /dev/null
+++ b/audio/libechonest/files/patch-CMakeLists.txt
@@ -0,0 +1,33 @@
+--- ./CMakeLists.txt.orig 2012-07-21 19:14:04.000000000 +0200
++++ ./CMakeLists.txt 2013-02-13 00:12:06.000000000 +0100
+@@ -21,7 +21,7 @@
+ set( ECHONEST_LIB_PATCH_VERSION "1" )
+ set( ECHONEST_LIB_VERSION "${ECHONEST_LIB_MAJOR_VERSION}.${ECHONEST_LIB_MINOR_VERSION}.${ECHONEST_LIB_PATCH_VERSION}" )
+
+-set( ECHONEST_LIB_VERSION_SONAME "${ECHONEST_LIB_MAJOR_VERSION}.${ECHONEST_LIB_MINOR_VERSION}")
++set( ECHONEST_LIB_VERSION_SONAME "${ECHONEST_LIB_MAJOR_VERSION}")
+
+ if (CMAKE_COMPILER_IS_GNUCXX)
+ ADD_DEFINITIONS( -Wall -Wundef -Wcast-align -Wchar-subscripts -Wpointer-arith
+@@ -32,9 +32,9 @@
+ endif()
+
+ # disable -Werror on ARM since Qt containers cause a lot of alignment warnings
+- if ( NOT CMAKE_SYSTEM_PROCESSOR MATCHES "arm" )
+- add_definitions( -Werror )
+- endif()
++ #if ( NOT CMAKE_SYSTEM_PROCESSOR MATCHES "arm" )
++ # add_definitions( -Werror )
++ #endif()
+
+ # to be added:
+ # -Wshadow
+@@ -79,7 +79,7 @@
+ ${CMAKE_CURRENT_BINARY_DIR}/libechonest.pc
+ @ONLY)
+ INSTALL (FILES ${CMAKE_CURRENT_BINARY_DIR}/libechonest.pc
+- DESTINATION lib${LIB_SUFFIX}/pkgconfig)
++ DESTINATION libdata/pkgconfig)
+ ENDIF (NOT WIN32)
+
+ include(CPack)