aboutsummaryrefslogtreecommitdiffstats
path: root/audio/liblastfm/files
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-07-28 11:54:14 +0800
committerswills <swills@FreeBSD.org>2011-07-28 11:54:14 +0800
commitf3c20aab3ed54d8eaf93e959c5d126853a485af0 (patch)
tree994f1be862083a10ac32770fd05f46be9fcdcbf0 /audio/liblastfm/files
parentb01652362e35dd9c27afc570c10eb208006cbb58 (diff)
downloadfreebsd-ports-gnome-f3c20aab3ed54d8eaf93e959c5d126853a485af0.tar.gz
freebsd-ports-gnome-f3c20aab3ed54d8eaf93e959c5d126853a485af0.tar.zst
freebsd-ports-gnome-f3c20aab3ed54d8eaf93e959c5d126853a485af0.zip
- A better fix for Ruby 1.9 compilation
Diffstat (limited to 'audio/liblastfm/files')
-rw-r--r--audio/liblastfm/files/patch-no-ftools36
1 files changed, 36 insertions, 0 deletions
diff --git a/audio/liblastfm/files/patch-no-ftools b/audio/liblastfm/files/patch-no-ftools
new file mode 100644
index 000000000000..3488045085c4
--- /dev/null
+++ b/audio/liblastfm/files/patch-no-ftools
@@ -0,0 +1,36 @@
+--- admin/findsrc.rb.orig 2010-09-19 10:35:34.783333338 +0200
++++ admin/findsrc.rb 2010-09-19 10:35:57.730000003 +0200
+@@ -1,6 +1,6 @@
+ #!/usr/bin/ruby
+ require 'find'
+-require "#{File.dirname __FILE__}/platform"
++require "#{Dir.getwd}/admin/platform.rb"
+
+ def findsrc dir='.'
+ excludes = ['.svn','.git','_include','tests','_build']
+--- admin/qpp.orig 2010-09-19 10:36:09.276666670 +0200
++++ admin/qpp 2010-09-19 10:36:16.926666670 +0200
+@@ -2,9 +2,8 @@
+ # Creates a qmake .pro file for all valid SOURCES, HEADERS, FORMS and
+ # RESOURCES under each argument to ARGV as directories
+
+-cwd=File.dirname __FILE__
+ require 'find'
+-require "#{cwd}/findsrc"
++require "#{Dir.getwd}/admin/findsrc.rb"
+
+ sources = Array.new
+ headers = Array.new
+--- admin/Makefile.rb.orig 2010-09-19 10:35:38.086666671 +0200
++++ admin/Makefile.rb 2010-09-19 10:36:05.816666671 +0200
+@@ -4,9 +4,8 @@
+ # and then creates the directory _include and creates files named after the
+ # class names in there which #include the file that contains the class
+
+-cwd = File.dirname( __FILE__ )
+ require 'find'
+-require "#{cwd}/platform.rb"
++require "#{Dir.getwd}/admin/platform.rb"
+
+
+ ######################################################################### defs