aboutsummaryrefslogtreecommitdiffstats
path: root/audio/libmusicbrainz4
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2012-07-27 21:28:58 +0800
committermakc <makc@FreeBSD.org>2012-07-27 21:28:58 +0800
commit8e014ae27668e6e597a1225f2cabe3f160937575 (patch)
tree188bcb222b318b54f65e273f2cc19694a2765baa /audio/libmusicbrainz4
parentd75da2609ef6faa17ad73e666a06994a71fb2ae9 (diff)
downloadfreebsd-ports-gnome-8e014ae27668e6e597a1225f2cabe3f160937575.tar.gz
freebsd-ports-gnome-8e014ae27668e6e597a1225f2cabe3f160937575.tar.zst
freebsd-ports-gnome-8e014ae27668e6e597a1225f2cabe3f160937575.zip
- Use LATEST_LINK instead of defining the version in PORTNAME
- while I'm here, respect LOCALBASE and thus remove needless dependency on pkg-config. pkg-config is often used by cmake as auxiliary tool to populate search paths. Until stuff is located at standard location, there is no need for pkg-config utility. [1] PR: ports/169904 Submitted by: Jason E. Hale (maintainer) Approved by: maintainer via irc [1]
Diffstat (limited to 'audio/libmusicbrainz4')
-rw-r--r--audio/libmusicbrainz4/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/audio/libmusicbrainz4/Makefile b/audio/libmusicbrainz4/Makefile
index a153d6133940..6ac39c7da886 100644
--- a/audio/libmusicbrainz4/Makefile
+++ b/audio/libmusicbrainz4/Makefile
@@ -5,11 +5,10 @@
# $FreeBSD$
#
-PORTNAME= libmusicbrainz4
+PORTNAME= libmusicbrainz
PORTVERSION= 4.0.3
CATEGORIES= audio
-MASTER_SITES= https://cloud.github.com/downloads/metabrainz/${PORTNAME:S/4//}/
-DISTNAME= ${PORTNAME:S/4//}-${PORTVERSION}
+MASTER_SITES= https://cloud.github.com/downloads/metabrainz/${PORTNAME}/
MAINTAINER= bsdkaffee@gmail.com
COMMENT= MusicBrainz client library for audio metadata lookup
@@ -18,8 +17,9 @@ LICENSE= LGPL21
LIB_DEPENDS= neon:${PORTSDIR}/www/neon29
+LATEST_LINK= ${PORTNAME}4
+
USE_CMAKE= yes
-USE_GNOME= pkgconfig
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
@@ -27,5 +27,7 @@ MAKE_JOBS_SAFE= yes
post-patch:
${REINPLACE_CMD} -e '/pkgconfig/s|$${LIB_INSTALL_DIR}|libdata|' \
${WRKSRC}/CMakeLists.txt
+ ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ ${WRKSRC}/cmake/modules/*.cmake
.include <bsd.port.mk>