aboutsummaryrefslogtreecommitdiffstats
path: root/audio/liboggz
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-10-08 06:43:36 +0800
committersat <sat@FreeBSD.org>2006-10-08 06:43:36 +0800
commit493b88cdab5b1d3f7b1563903f59069332a22ed7 (patch)
tree0e3bc9900f57f2ff1e231cd65eda429ea9359e8e /audio/liboggz
parentc6cd03d1324b0420d2d9a3b57bf98d07a07f050c (diff)
downloadfreebsd-ports-gnome-493b88cdab5b1d3f7b1563903f59069332a22ed7.tar.gz
freebsd-ports-gnome-493b88cdab5b1d3f7b1563903f59069332a22ed7.tar.zst
freebsd-ports-gnome-493b88cdab5b1d3f7b1563903f59069332a22ed7.zip
Add port audio/liboggz:
Oggz provides a simple programming interface for reading and writing Ogg files and streams. Ogg is an interleaving data container developed by Monty at Xiph.Org, originally to support the Ogg Vorbis audio format. liboggz supports the flexibility afforded by the Ogg file format while presenting the following API niceties: * Strict adherence to the formatting requirements of Ogg bitstreams, to ensure that only valid bitstreams are generated * A simple, callback based open/read/close or open/write/close interface to raw Ogg files * A customisable seeking abstraction for seeking on multitrack Ogg data * A packet queue for feeding incoming packets for writing, with callback based notification when this queue is empty * A means of overriding the IO functions used by Oggz, for easier integration with media frameworks and similar systems. * A handy table structure for storing information on each logical bitstream WWW: http://www.annodex.net/software/liboggz/html/
Diffstat (limited to 'audio/liboggz')
-rw-r--r--audio/liboggz/Makefile29
-rw-r--r--audio/liboggz/distinfo3
-rw-r--r--audio/liboggz/pkg-descr20
-rw-r--r--audio/liboggz/pkg-plist104
4 files changed, 156 insertions, 0 deletions
diff --git a/audio/liboggz/Makefile b/audio/liboggz/Makefile
new file mode 100644
index 000000000000..8207a5bca441
--- /dev/null
+++ b/audio/liboggz/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: liboggz
+# Date created: 08 October 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= liboggz
+DISTVERSION= 0.9.5
+CATEGORIES= audio
+MASTER_SITES= http://www.annodex.net/software/liboggz/download/ CSME
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Simple Ogg API
+
+LIB_DEPENDS= ogg.5:${PORTSDIR}/audio/libogg
+
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-ogg=${LOCALBASE} --program-transform-name=""
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^pkgconfigdir/s!=.*!= ${PREFIX}/libdata/pkgconfig!' ${WRKSRC}/Makefile.in
+.ifdef NOPORTDOCS
+ @${REINPLACE_CMD} -e '/^install-data-am/s!install-data-local!!' ${WRKSRC}/doc/Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/liboggz/distinfo b/audio/liboggz/distinfo
new file mode 100644
index 000000000000..4a8cc5900cb0
--- /dev/null
+++ b/audio/liboggz/distinfo
@@ -0,0 +1,3 @@
+MD5 (liboggz-0.9.5.tar.gz) = 781fab29dea3c5e9d39ecbd1d007fb98
+SHA256 (liboggz-0.9.5.tar.gz) = 4a9fb386b0609444de021c4bbb8c8d6ba65e93dca86ea68b3f72b0862e2e886c
+SIZE (liboggz-0.9.5.tar.gz) = 554693
diff --git a/audio/liboggz/pkg-descr b/audio/liboggz/pkg-descr
new file mode 100644
index 000000000000..fd3d206a4166
--- /dev/null
+++ b/audio/liboggz/pkg-descr
@@ -0,0 +1,20 @@
+Oggz provides a simple programming interface for reading and writing
+Ogg files and streams. Ogg is an interleaving data container developed
+by Monty at Xiph.Org, originally to support the Ogg Vorbis audio
+format.
+
+liboggz supports the flexibility afforded by the Ogg file format while
+presenting the following API niceties:
+* Strict adherence to the formatting requirements of Ogg bitstreams,
+ to ensure that only valid bitstreams are generated
+* A simple, callback based open/read/close or open/write/close interface
+ to raw Ogg files
+* A customisable seeking abstraction for seeking on multitrack Ogg data
+* A packet queue for feeding incoming packets for writing, with
+ callback based notification when this queue is empty
+* A means of overriding the IO functions used by Oggz, for easier
+ integration with media frameworks and similar systems.
+* A handy table structure for storing information on each logical
+ bitstream
+
+WWW: http://www.annodex.net/software/liboggz/html/
diff --git a/audio/liboggz/pkg-plist b/audio/liboggz/pkg-plist
new file mode 100644
index 000000000000..20f234ddee5c
--- /dev/null
+++ b/audio/liboggz/pkg-plist
@@ -0,0 +1,104 @@
+bin/oggz-scan
+bin/oggz-validate
+bin/oggzdiff
+bin/oggzdump
+bin/oggzinfo
+bin/oggzmerge
+bin/oggzrip
+include/oggz/oggz.h
+include/oggz/oggz_constants.h
+include/oggz/oggz_deprecated.h
+include/oggz/oggz_io.h
+include/oggz/oggz_read.h
+include/oggz/oggz_seek.h
+include/oggz/oggz_table.h
+include/oggz/oggz_write.h
+lib/liboggz.a
+lib/liboggz.la
+lib/liboggz.so.3
+lib/liboggz.so
+libdata/pkgconfig/oggz.pc
+@dirrm include/oggz
+@dirrmtry libdata/pkgconfig
+%%PORTDOCS%%%%DOCSDIR%%/html/dir_000000.html
+%%PORTDOCS%%%%DOCSDIR%%/html/dir_000001.html
+%%PORTDOCS%%%%DOCSDIR%%/html/dirs.html
+%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
+%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.png
+%%PORTDOCS%%%%DOCSDIR%%/html/files.html
+%%PORTDOCS%%%%DOCSDIR%%/html/forcefeed.png
+%%PORTDOCS%%%%DOCSDIR%%/html/globals.html
+%%PORTDOCS%%%%DOCSDIR%%/html/globals_defs.html
+%%PORTDOCS%%%%DOCSDIR%%/html/globals_enum.html
+%%PORTDOCS%%%%DOCSDIR%%/html/globals_eval.html
+%%PORTDOCS%%%%DOCSDIR%%/html/globals_func.html
+%%PORTDOCS%%%%DOCSDIR%%/html/globals_type.html
+%%PORTDOCS%%%%DOCSDIR%%/html/group__basics.html
+%%PORTDOCS%%%%DOCSDIR%%/html/group__building.html
+%%PORTDOCS%%%%DOCSDIR%%/html/group__configuration.html
+%%PORTDOCS%%%%DOCSDIR%%/html/group__force__feed.html
+%%PORTDOCS%%%%DOCSDIR%%/html/group__hungry.html
+%%PORTDOCS%%%%DOCSDIR%%/html/group__install.html
+%%PORTDOCS%%%%DOCSDIR%%/html/group__metric.html
+%%PORTDOCS%%%%DOCSDIR%%/html/group__read__api.html
+%%PORTDOCS%%%%DOCSDIR%%/html/group__seek__api.html
+%%PORTDOCS%%%%DOCSDIR%%/html/group__seek__semantics.html
+%%PORTDOCS%%%%DOCSDIR%%/html/group__write__api.html
+%%PORTDOCS%%%%DOCSDIR%%/html/hungry.png
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/modules.html
+%%PORTDOCS%%%%DOCSDIR%%/html/oggz_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/oggz_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/oggz__constants_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/oggz__constants_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/oggz__deprecated_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/oggz__deprecated_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/oggz__io_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/oggz__io_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/oggz__read_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/oggz__read_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/oggz__seek_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/oggz__seek_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/oggz__table_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/oggz__table_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/oggz__write_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/oggz__write_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tab_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/tab_l.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/tab_r.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/tabs.css
+%%PORTDOCS%%%%DOCSDIR%%/latex/FreeSans.ttf
+%%PORTDOCS%%%%DOCSDIR%%/latex/Helvetica.ttf
+%%PORTDOCS%%%%DOCSDIR%%/latex/Makefile
+%%PORTDOCS%%%%DOCSDIR%%/latex/dir_000000.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/dir_000001.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/dirs.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/doxygen.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/files.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/forcefeed.eps
+%%PORTDOCS%%%%DOCSDIR%%/latex/group__basics.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/group__building.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/group__configuration.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/group__force__feed.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/group__hungry.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/group__install.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/group__metric.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/group__read__api.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/group__seek__api.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/group__seek__semantics.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/group__write__api.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/hungry.eps
+%%PORTDOCS%%%%DOCSDIR%%/latex/index.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/modules.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/oggz_8h.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/oggz__constants_8h.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/oggz__deprecated_8h.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/oggz__io_8h.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/oggz__read_8h.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/oggz__seek_8h.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/oggz__table_8h.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/oggz__write_8h.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/refman.tex
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/latex
+%%PORTDOCS%%@dirrm %%DOCSDIR%%