aboutsummaryrefslogtreecommitdiffstats
path: root/audio/libsamplerate
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2003-02-03 20:40:41 +0800
committersobomax <sobomax@FreeBSD.org>2003-02-03 20:40:41 +0800
commit31d86952174223f0818dbf748e85d2cf797bd531 (patch)
treeb6ee45534dc53bb96bd20334560b0e92325c34b7 /audio/libsamplerate
parent7ec392a71d4a16d42815436571bb594035f53ed3 (diff)
downloadfreebsd-ports-gnome-31d86952174223f0818dbf748e85d2cf797bd531.tar.gz
freebsd-ports-gnome-31d86952174223f0818dbf748e85d2cf797bd531.tar.zst
freebsd-ports-gnome-31d86952174223f0818dbf748e85d2cf797bd531.zip
Add libsamplerate 0.0.14, secret Rabbit Code is a Sample Rate
Converter for audio. PR: 47821 Submitted by: David Magda <dmagda+fbugs@ee.ryerson.ca>
Diffstat (limited to 'audio/libsamplerate')
-rw-r--r--audio/libsamplerate/Makefile46
-rw-r--r--audio/libsamplerate/distinfo1
-rw-r--r--audio/libsamplerate/files/patch-configure13
-rw-r--r--audio/libsamplerate/pkg-comment1
-rw-r--r--audio/libsamplerate/pkg-descr10
-rw-r--r--audio/libsamplerate/pkg-plist20
6 files changed, 91 insertions, 0 deletions
diff --git a/audio/libsamplerate/Makefile b/audio/libsamplerate/Makefile
new file mode 100644
index 000000000000..0c623287bf9a
--- /dev/null
+++ b/audio/libsamplerate/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: libsamplerate
+# Date created: 2 February 2003
+# Whom: <dmagda+libsamplerate@ee.ryerson.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsamplerate
+PORTVERSION= 0.0.14
+CATEGORIES= audio
+MASTER_SITES= http://www.mega-nerd.com/SRC/
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile
+RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --disable-gcc-pipe
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+PORTDOCS= SRC.png SRC.css index.html license.html history.html \
+ download.html lists.html quality.html win32.html \
+ api.html api_simple.html api_full.html api_misc.html
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|libdir[)]/pkgconfig|prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/libsamplerate/distinfo b/audio/libsamplerate/distinfo
new file mode 100644
index 000000000000..431bb3f4118b
--- /dev/null
+++ b/audio/libsamplerate/distinfo
@@ -0,0 +1 @@
+MD5 (libsamplerate-0.0.14.tar.gz) = 485a6e19d6ee0c5edf65e7be9ae02422
diff --git a/audio/libsamplerate/files/patch-configure b/audio/libsamplerate/files/patch-configure
new file mode 100644
index 000000000000..4152d93d8361
--- /dev/null
+++ b/audio/libsamplerate/files/patch-configure
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- configure 2003/02/03 12:25:06 1.1
++++ configure 2003/02/03 12:25:19
+@@ -7849,6 +7849,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/libsamplerate/pkg-comment b/audio/libsamplerate/pkg-comment
new file mode 100644
index 000000000000..f3efca059982
--- /dev/null
+++ b/audio/libsamplerate/pkg-comment
@@ -0,0 +1 @@
+Secret Rabbit Code is a Sample Rate Converter for audio
diff --git a/audio/libsamplerate/pkg-descr b/audio/libsamplerate/pkg-descr
new file mode 100644
index 000000000000..4b3d0aa36c29
--- /dev/null
+++ b/audio/libsamplerate/pkg-descr
@@ -0,0 +1,10 @@
+Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for
+audio.
+
+SRC is capable of arbitrary and time varying conversions ; from
+downsampling by a factor of 12 to upsampling by the same factor.
+Arbitrary in this case means that the ratio of input and output sample
+rates can be an irrational number. The conversion ratio can also vary
+with time for speeding up and slowing down effects.
+
+WWW: http://www.mega-nerd.com/SRC/
diff --git a/audio/libsamplerate/pkg-plist b/audio/libsamplerate/pkg-plist
new file mode 100644
index 000000000000..2003cc9a3fdf
--- /dev/null
+++ b/audio/libsamplerate/pkg-plist
@@ -0,0 +1,20 @@
+bin/sndfile-resample
+include/samplerate.h
+lib/libsamplerate.a
+lib/libsamplerate.so
+lib/libsamplerate.so.0
+libdata/pkgconfig/samplerate.pc
+%%PORTDOCS%%share/doc/libsamplerate/SRC.png
+%%PORTDOCS%%share/doc/libsamplerate/SRC.css
+%%PORTDOCS%%share/doc/libsamplerate/index.html
+%%PORTDOCS%%share/doc/libsamplerate/license.html
+%%PORTDOCS%%share/doc/libsamplerate/history.html
+%%PORTDOCS%%share/doc/libsamplerate/download.html
+%%PORTDOCS%%share/doc/libsamplerate/lists.html
+%%PORTDOCS%%share/doc/libsamplerate/quality.html
+%%PORTDOCS%%share/doc/libsamplerate/win32.html
+%%PORTDOCS%%share/doc/libsamplerate/api.html
+%%PORTDOCS%%share/doc/libsamplerate/api_simple.html
+%%PORTDOCS%%share/doc/libsamplerate/api_full.html
+%%PORTDOCS%%share/doc/libsamplerate/api_misc.html
+@dirrm %%PORTDOCS%%share/doc/libsamplerate