aboutsummaryrefslogtreecommitdiffstats
path: root/audio/libsidplay2
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-08-19 02:11:00 +0800
committerkrion <krion@FreeBSD.org>2004-08-19 02:11:00 +0800
commit4c11b045da68c3c91ee9239fa950f609e3929ee0 (patch)
tree6d03cce8e8763faa64fad45ab7b7f8d9ff821de4 /audio/libsidplay2
parent5918dd43c7695072ac49acb8d81b8fc3d100e98f (diff)
downloadfreebsd-ports-gnome-4c11b045da68c3c91ee9239fa950f609e3929ee0.tar.gz
freebsd-ports-gnome-4c11b045da68c3c91ee9239fa950f609e3929ee0.tar.zst
freebsd-ports-gnome-4c11b045da68c3c91ee9239fa950f609e3929ee0.zip
Fix build with gcc-3.4
PR: ports/70627 Submitted by: Ports Fury
Diffstat (limited to 'audio/libsidplay2')
-rw-r--r--audio/libsidplay2/Makefile8
-rw-r--r--audio/libsidplay2/files/patch-libsidplay::include::sidplay::SmartPtr.h26
2 files changed, 27 insertions, 7 deletions
diff --git a/audio/libsidplay2/Makefile b/audio/libsidplay2/Makefile
index a2eb0312ff9f..90f26a25ebc0 100644
--- a/audio/libsidplay2/Makefile
+++ b/audio/libsidplay2/Makefile
@@ -26,14 +26,8 @@ LIBTOOLFILES= builders/hardsid-builder/configure \
resid/configure
INSTALLS_SHLIB= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile with gcc 3.4.2"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|<malloc\.h>|<stdlib.h>|g' \
${WRKSRC}/libsidutils/src/ini/ini.cpp
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/libsidplay2/files/patch-libsidplay::include::sidplay::SmartPtr.h b/audio/libsidplay2/files/patch-libsidplay::include::sidplay::SmartPtr.h
new file mode 100644
index 000000000000..df50ab655518
--- /dev/null
+++ b/audio/libsidplay2/files/patch-libsidplay::include::sidplay::SmartPtr.h
@@ -0,0 +1,26 @@
+--- libsidplay/include/sidplay/SmartPtr.h.orig Tue Jun 15 05:08:04 2004
++++ libsidplay/include/sidplay/SmartPtr.h Wed Aug 18 00:47:50 2004
+@@ -211,16 +211,16 @@
+ {
+ if ( bufferLen >= 1 )
+ {
+- pBufCurrent = ( bufBegin = buffer );
+- bufEnd = bufBegin + bufferLen;
+- bufLen = bufferLen;
+- status = true;
++ this->pBufCurrent = ( this->bufBegin = buffer );
++ this->bufEnd = this->bufBegin + bufferLen;
++ this->bufLen = bufferLen;
++ this->status = true;
+ }
+ else
+ {
+- pBufCurrent = bufBegin = bufEnd = 0;
+- bufLen = 0;
+- status = false;
++ this->pBufCurrent = this->bufBegin = this->bufEnd = 0;
++ this->bufLen = 0;
++ this->status = false;
+ }
+ }
+ };