aboutsummaryrefslogtreecommitdiffstats
path: root/audio/libsndfile
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2012-03-07 12:44:06 +0800
committerbf <bf@FreeBSD.org>2012-03-07 12:44:06 +0800
commitab8990f1a7530302ec367835d312fe6ee92e7472 (patch)
treea30e18670a9a456a0f3c0bebafc2fd7d5176d81a /audio/libsndfile
parent0001a150523cc2aa29bf7910740f9df74e9a509e (diff)
downloadfreebsd-ports-gnome-ab8990f1a7530302ec367835d312fe6ee92e7472.tar.gz
freebsd-ports-gnome-ab8990f1a7530302ec367835d312fe6ee92e7472.tar.zst
freebsd-ports-gnome-ab8990f1a7530302ec367835d312fe6ee92e7472.zip
disable some machine-dependent code by default; add a test target
Diffstat (limited to 'audio/libsndfile')
-rw-r--r--audio/libsndfile/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/audio/libsndfile/Makefile b/audio/libsndfile/Makefile
index 6681e86175a3..3c27f44e4410 100644
--- a/audio/libsndfile/Makefile
+++ b/audio/libsndfile/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libsndfile
PORTVERSION= 1.0.25
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.mega-nerd.com/libsndfile/files/
@@ -34,10 +35,17 @@ MAN1= sndfile-concat.1 sndfile-cmp.1 sndfile-convert.1 \
PORTDOCS= AUTHORS ChangeLog NEWS README libsndfile.css \
new_file_type.HOWTO libsndfile.jpg *.html
-OPTIONS= EXTERNAL "Enable FLAC and Ogg Vorbis support" on
+OPTIONS= CPU_CLIP "Allow machine-dependent clipping" off \
+ EXTERNAL "Enable FLAC and Ogg Vorbis support" on
.include <bsd.port.pre.mk>
+.if !defined(WITH_CPU_CLIP)
+CONFIGURE_ARGS+= --disable-cpu-clip
+.else
+MANUAL_PACKAGE_BUILD= WITH_CPU_CLIP may customize the package for the build machine
+.endif
+
.if defined(WITHOUT_EXTERNAL)
CONFIGURE_ARGS+=--disable-external-libs
.else
@@ -48,6 +56,10 @@ LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac \
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s/ doc / /g' ${WRKSRC}/Makefile.in
+check regression-test test: build
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} ${MAKE_ARGS} \
+ check
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}