aboutsummaryrefslogtreecommitdiffstats
path: root/audio/lingot
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-03-06 01:07:43 +0800
committermiwi <miwi@FreeBSD.org>2013-03-06 01:07:43 +0800
commitb5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7 (patch)
tree268d74f9d8738f78b0c895672044611aa6343387 /audio/lingot
parent4c148339a17778393b116c6e7051a9bc484e786a (diff)
downloadfreebsd-ports-gnome-b5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7.tar.gz
freebsd-ports-gnome-b5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7.tar.zst
freebsd-ports-gnome-b5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7.zip
- Convert to OptionsNG
- Trim header Reviewed by: beat, bapt, kwm
Diffstat (limited to 'audio/lingot')
-rw-r--r--audio/lingot/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/audio/lingot/Makefile b/audio/lingot/Makefile
index 25a2e11082b0..b6a06458acda 100644
--- a/audio/lingot/Makefile
+++ b/audio/lingot/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: lingot
-# Date created: 2011-10-17
-# Whom: Bartoletti <coder@tuxfamily.org>
-#
+# Created by: Bartoletti <coder@tuxfamily.org>
# $FreeBSD$
-#
PORTNAME= lingot
PORTVERSION= 0.9.1
@@ -25,12 +21,12 @@ USE_GETTEXT= yes
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS= JACK "Enable jack plugin" on \
- ALSA "Enable alsa plugin" off
+OPTIONS_DEFINE= JACK ALSA
+OPTIONS_DEFAULT= JACK
.include <bsd.port.options.mk>
-.if defined(WITH_JACK)
+.if ${PORT_OPTIONS:MJACK}
LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack \
samplerate.1:${PORTSDIR}/audio/libsamplerate
CONFIGURE_ARGS+=--enable-jack
@@ -38,7 +34,7 @@ CONFIGURE_ARGS+=--enable-jack
CONFIGURE_ARGS+=--disable-jack
.endif
-.if defined(WITH_ALSA)
+.if ${PORT_OPTIONS:MALSA}
LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
RUN_DEPENDS+= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/audio/alsa-plugins
CONFIGURE_ARGS+=--enable-alsa