aboutsummaryrefslogtreecommitdiffstats
path: root/audio/linux-arts/Makefile
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2003-10-06 19:54:10 +0800
committerbms <bms@FreeBSD.org>2003-10-06 19:54:10 +0800
commit63a550a671b7eb7bd4a6e5389f5440f66035d7d8 (patch)
tree282fdf514ea53056ac62a249e71cbd4fd1033204 /audio/linux-arts/Makefile
parentf112d1749399190d4b8abe8e3f76a91127beb914 (diff)
downloadfreebsd-ports-gnome-63a550a671b7eb7bd4a6e5389f5440f66035d7d8.tar.gz
freebsd-ports-gnome-63a550a671b7eb7bd4a6e5389f5440f66035d7d8.tar.zst
freebsd-ports-gnome-63a550a671b7eb7bd4a6e5389f5440f66035d7d8.zip
Add the Linux version of the KDE arts sound library (it is an unlikely
dependency for the Dell RAID tools). Reviewed by: edwin
Diffstat (limited to 'audio/linux-arts/Makefile')
-rw-r--r--audio/linux-arts/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/audio/linux-arts/Makefile b/audio/linux-arts/Makefile
new file mode 100644
index 000000000000..5e79667a5503
--- /dev/null
+++ b/audio/linux-arts/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: linux-arts
+# Date created: 6 October 2003
+# Whom: bms@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= arts
+PORTVERSION= 1.0.3
+CATEGORIES= audio kde linux
+MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
+MASTER_SITE_SUBDIR= 8.0/en/os/${MACHINE_ARCH}/RedHat/RPMS
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.1$/-1/}-1.${MACHINE_ARCH}
+EXTRACT_SUFX= .rpm
+EXTRACT_ONLY=
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Audio system for the KDE integrated X11 desktop
+
+BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
+
+USE_LINUX_PREFIX= yes
+LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
+
+ONLY_FOR_ARCHS= i386
+DIST_SUBDIR= rpm
+NO_BUILD= yes
+NO_FILTER_SHLIBS= yes
+PLIST= ${MASTERDIR}/pkg-plist.${MACHINE_ARCH}
+MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
+
+DBPATH= /var/lib/rpm
+RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
+ --nodeps --replacepkgs
+RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
+
+do-install:
+ @${LOCALBASE}/bin/rpm -U ${RPMFLAGS} ${RPMDIR}/${DISTFILES}
+ @${LDCONFIG_LINUX}
+
+.include <bsd.port.mk>