aboutsummaryrefslogtreecommitdiffstats
path: root/audio/linux-shoutcast
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2007-04-01 03:56:19 +0800
committergabor <gabor@FreeBSD.org>2007-04-01 03:56:19 +0800
commit1229782f69da6f5de28e93edd167fa49a51bdf50 (patch)
tree47a3d2cee4e1393b90060c5fd9a23a144ae0f946 /audio/linux-shoutcast
parent2351f6995d0d4d0810b4aae13d99fbf9892aace3 (diff)
downloadfreebsd-ports-gnome-1229782f69da6f5de28e93edd167fa49a51bdf50.tar.gz
freebsd-ports-gnome-1229782f69da6f5de28e93edd167fa49a51bdf50.tar.zst
freebsd-ports-gnome-1229782f69da6f5de28e93edd167fa49a51bdf50.zip
- Remove DESTDIR support from my ports as it is useless now. New implementation
is coming.
Diffstat (limited to 'audio/linux-shoutcast')
-rw-r--r--audio/linux-shoutcast/Makefile12
-rw-r--r--audio/linux-shoutcast/pkg-install7
2 files changed, 7 insertions, 12 deletions
diff --git a/audio/linux-shoutcast/Makefile b/audio/linux-shoutcast/Makefile
index 19261aa263e9..f6aa7a671494 100644
--- a/audio/linux-shoutcast/Makefile
+++ b/audio/linux-shoutcast/Makefile
@@ -36,11 +36,11 @@ post-patch:
${WRKSRC}/sc_serv.conf
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/sc_serv ${TARGETDIR}/sbin
- @${MKDIR} ${TARGETDIR}/etc/shoutcast
- @${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${TARGETDIR}/etc/shoutcast/sc_serv.conf.sample
- @[ -f ${TARGETDIR}/etc/shoutcast/sc_serv.conf ] || \
- ${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${TARGETDIR}/etc/shoutcast/sc_serv.conf
+ @${INSTALL_PROGRAM} ${WRKSRC}/sc_serv ${PREFIX}/sbin
+ @${MKDIR} ${PREFIX}/etc/shoutcast
+ @${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${PREFIX}/etc/shoutcast/sc_serv.conf.sample
+ @[ -f ${PREFIX}/etc/shoutcast/sc_serv.conf ] || \
+ ${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${PREFIX}/etc/shoutcast/sc_serv.conf
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -49,6 +49,6 @@ do-install:
post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${BRANDELF} -t Linux ${TARGETDIR}/sbin/sc_serv
+ @${BRANDELF} -t Linux ${PREFIX}/sbin/sc_serv
.include <bsd.port.mk>
diff --git a/audio/linux-shoutcast/pkg-install b/audio/linux-shoutcast/pkg-install
index 75387ad52143..2b6c96b93a64 100644
--- a/audio/linux-shoutcast/pkg-install
+++ b/audio/linux-shoutcast/pkg-install
@@ -8,12 +8,7 @@ SC_GROUP=shoutcast
SC_USER=shoutcast
SC_SHELL=/bin/sh
SC_HOME=/nonexistent
-
-if [ -n "${DESTDIR}" ] ; then
- PW="/usr/sbin/chroot ${DESTDIR} /usr/sbin/pw"
-else
- PW="/usr/sbin/pw"
-fi
+PW="/usr/sbin/pw"
if ! ${PW} show group ${SC_GROUP} -q >/dev/null; then
gid=210