aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mac
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-04-08 16:29:08 +0800
committerdanfe <danfe@FreeBSD.org>2015-04-08 16:29:08 +0800
commit2b478e84c2724dbf92ce329245bab6b2872bebdf (patch)
tree57af34b6292a4897487250811077061a4e045332 /audio/mac
parent2ba416bd712ffdb5865d9125ceeac18f35736242 (diff)
downloadfreebsd-ports-gnome-2b478e84c2724dbf92ce329245bab6b2872bebdf.tar.gz
freebsd-ports-gnome-2b478e84c2724dbf92ce329245bab6b2872bebdf.tar.zst
freebsd-ports-gnome-2b478e84c2724dbf92ce329245bab6b2872bebdf.zip
- Update to the most recent version maintained by Jason Jordan as part of
his 3.99-u4-b5-sX series. Unfortunately we cannot assign it directly to DISTVERSION without having to bump PORTEPOCH, so stick to 3.99.4.5.7 for the time being (note that upstream Monkey's Audio SDK is at version 4.16 right now; but seems that no one ported it to Linux/Unix -- folks prefer to maintain old 3.xx port instead; mention this in the port description) - Build in "shntool-enabled" mode by default (-DSHNTOOL); this is also in line with how most GNU/Linux distributions package it - Install couple of useful documentation files, but first beautify them a bit: convert to UTF-8 and append missing newline at EOF; sed(1) command might look unnatural, but it is compatible with both GNU and BSD sed(1) implementations (cf.: '-nep' is GNU-only, and '$G' is new BSD-only); we prefer ${SED} over ${ECHO_CMD} >> because it is shorter and allows for linear piping (no subshell and stream joining required) - Convert in-place configure script editing to a patch as we also have to teach it that elftoolchain's strip(1) can strip libraries; staying with REINPLACE_CMD would make it harder to read compared to normal patchfile - Remove duplicate GNU_CONFIGURE line, bogusly added by bapt@ in r353071
Diffstat (limited to 'audio/mac')
-rw-r--r--audio/mac/Makefile29
-rw-r--r--audio/mac/distinfo4
-rw-r--r--audio/mac/files/patch-configure20
-rw-r--r--audio/mac/pkg-descr3
4 files changed, 43 insertions, 13 deletions
diff --git a/audio/mac/Makefile b/audio/mac/Makefile
index 6cf553c80a3f..20d052faa596 100644
--- a/audio/mac/Makefile
+++ b/audio/mac/Makefile
@@ -2,35 +2,42 @@
# $FreeBSD$
PORTNAME= mac
-PORTVERSION= 3.99.4.5
-PORTREVISION= 2
+PORTVERSION= 3.99.4.5.7
CATEGORIES= audio
-MASTER_SITES= http://etree.org/shnutils/shntool/support/formats/ape/unix/3.99-u4-b5/ \
+MASTER_SITES= http://etree.org/shnutils/shntool/support/formats/ape/unix/3.99-u4-b5-s7/ \
http://freebsd.nsu.ru/distfiles/
-DISTNAME= ${PORTNAME}-3.99-u4-b5
+DISTNAME= ${PORTNAME}-3.99-u4-b5-s7
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Monkey's Audio lossless codec
-USES= libtool
+USES= iconv:build libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
+CPPFLAGS+= -DSHNTOOL
+
+PORTDOCS= Credits.txt History.txt
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386" || ${ARCH} == "amd64"
BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|-O3||' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e '/nRetVal = 0/s|int|intptr_t|' \
- ${WRKSRC}/src/MACLib/APEDecompress.cpp
-
post-install:
cd ${WRKSRC}/src/MACLib && ${INSTALL_DATA} BitArray.h \
Prepare.h UnBitArrayBase.h ${STAGEDIR}${PREFIX}/include/mac
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+# Install couple of useful docfiles, but first beautify them a bit; cryptic
+# sed(1) construct is to append missing newline at EOF, in a way compatible
+# with both GNU and BSD sed(1) implementations.
+ ${ICONV_CMD} -f latin1 -t utf-8 ${WRKSRC}/src/Credits.txt | \
+ ${SED} -ne '$$G;P' > ${STAGEDIR}${DOCSDIR}/Credits.txt
+ ${SED} -ne '$$G;P' ${WRKSRC}/src/History.txt > \
+ ${STAGEDIR}${DOCSDIR}/History.txt
.include <bsd.port.post.mk>
diff --git a/audio/mac/distinfo b/audio/mac/distinfo
index 364c9f9f509a..9c0e1c5fa81a 100644
--- a/audio/mac/distinfo
+++ b/audio/mac/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mac-3.99-u4-b5.tar.gz) = d59ac5b1fa375a78eadbd5d9bb638ad0229185b42b562dbb04b0dab6475b6651
-SIZE (mac-3.99-u4-b5.tar.gz) = 421234
+SHA256 (mac-3.99-u4-b5-s7.tar.gz) = 9a735af2c56f05ee06b6e2ff719e902271299adf9e25cd3c9e4b28e8df3e30c5
+SIZE (mac-3.99-u4-b5-s7.tar.gz) = 450981
diff --git a/audio/mac/files/patch-configure b/audio/mac/files/patch-configure
new file mode 100644
index 000000000000..531d0ba82e43
--- /dev/null
+++ b/audio/mac/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig 2010-07-22 17:51:17 UTC
++++ configure
+@@ -3075,7 +3075,7 @@ fi
+
+
+ # Checks for programs.
+-CXXFLAGS="$CXXFLAGS -O3 -Wall -pedantic -Wno-long-long"
++CXXFLAGS="$CXXFLAGS -Wall -pedantic -Wno-long-long"
+ ac_ext=cpp
+ ac_cpp='$CXXCPP $CPPFLAGS'
+ ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
+@@ -11215,7 +11215,7 @@ striplib=
+ old_striplib=
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether stripping libraries is possible" >&5
+ $as_echo_n "checking whether stripping libraries is possible... " >&6; }
+-if test -n "$STRIP" && $STRIP -V 2>&1 | $GREP "GNU strip" >/dev/null; then
++if test -n "$STRIP" && $STRIP -V 2>&1 | $EGREP "GNU|elftoolchain" >/dev/null; then
+ test -z "$old_striplib" && old_striplib="$STRIP --strip-debug"
+ test -z "$striplib" && striplib="$STRIP --strip-unneeded"
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
diff --git a/audio/mac/pkg-descr b/audio/mac/pkg-descr
index 1256314a8a9d..27f8ea4667e0 100644
--- a/audio/mac/pkg-descr
+++ b/audio/mac/pkg-descr
@@ -3,4 +3,7 @@ compression (and decompression) ratio and time. Monkey's Audio Codec can
be used for personal, educational and non-commercial purposes. Commercial
usage requires prior written permission from Monkey's Audio author.
+This is community-maintained Unix port of earlier Monkey's Audio sources;
+it does not correspond to current official SDK releases (4.x).
+
WWW: http://www.monkeysaudio.com/