aboutsummaryrefslogtreecommitdiffstats
path: root/audio/maplay/files
diff options
context:
space:
mode:
authorjkh <jkh@FreeBSD.org>1995-02-14 16:32:41 +0800
committerjkh <jkh@FreeBSD.org>1995-02-14 16:32:41 +0800
commit30f6b345a27877872176e28660161dbbd01976b4 (patch)
treeed0ebfac5f9d1f91e64d7d19360cb21039ddfd36 /audio/maplay/files
parent82af1600715632ea84a8347253e649631e4aad31 (diff)
downloadfreebsd-ports-gnome-30f6b345a27877872176e28660161dbbd01976b4.tar.gz
freebsd-ports-gnome-30f6b345a27877872176e28660161dbbd01976b4.tar.zst
freebsd-ports-gnome-30f6b345a27877872176e28660161dbbd01976b4.zip
maplay port.
Diffstat (limited to 'audio/maplay/files')
-rw-r--r--audio/maplay/files/patch-ab31
1 files changed, 31 insertions, 0 deletions
diff --git a/audio/maplay/files/patch-ab b/audio/maplay/files/patch-ab
new file mode 100644
index 000000000000..0007783c7492
--- /dev/null
+++ b/audio/maplay/files/patch-ab
@@ -0,0 +1,31 @@
+*** work/Makefile.orig Tue Feb 14 08:18:41 1995
+--- work/Makefile Tue Feb 14 08:19:52 1995
+***************
+*** 39,45 ****
+
+ .SUFFIXES: .cc
+
+! install:
+ @./configuration.sh
+
+ all: maplay
+--- 39,45 ----
+
+ .SUFFIXES: .cc
+
+! pre-install:
+ @./configuration.sh
+
+ all: maplay
+***************
+*** 47,52 ****
+--- 47,55 ----
+ maplay: $(OBJS)
+ $(COMPILER) $(CFLAGS) $(OBJS) -o $@ $(LIBRARIES) -lm
+ -strip $@
++
++ install: all
++ ${INSTALL} -s -c -m 755 maplay ${PREFIX}/bin
+
+ .cc.o:
+ $(COMPILER) -c $(CFLAGS) $(INCLUDEDIRS) $*.cc -o $@