aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mctoolame-encoder
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-02-27 10:52:09 +0800
committerdanfe <danfe@FreeBSD.org>2013-02-27 10:52:09 +0800
commit0bbff1f9e30c0739dcaecfba4f29ae8f08de5035 (patch)
tree33e76b0589b089682acce4c6cec0e25c018108cb /audio/mctoolame-encoder
parenta8cb0c859c29c56c0124edfcbf01cb2183e11223 (diff)
downloadfreebsd-ports-gnome-0bbff1f9e30c0739dcaecfba4f29ae8f08de5035.tar.gz
freebsd-ports-gnome-0bbff1f9e30c0739dcaecfba4f29ae8f08de5035.tar.zst
freebsd-ports-gnome-0bbff1f9e30c0739dcaecfba4f29ae8f08de5035.zip
- Trim Makefile header per new style
- Remove not quite supported OPTIONS - Respect CC and CFLAGS in a saner way - Drop indefinite article from COMMENT - Unmute installation commands - Reformat port description text
Diffstat (limited to 'audio/mctoolame-encoder')
-rw-r--r--audio/mctoolame-encoder/Makefile52
-rw-r--r--audio/mctoolame-encoder/pkg-descr34
2 files changed, 27 insertions, 59 deletions
diff --git a/audio/mctoolame-encoder/Makefile b/audio/mctoolame-encoder/Makefile
index c6ff30e1cebf..f59707300331 100644
--- a/audio/mctoolame-encoder/Makefile
+++ b/audio/mctoolame-encoder/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mctooLAME encoder
-# Date created: Thu Mar 27 20:32:42 UTC 2003
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-#
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mctoolame
PORTVERSION= 0.1.a
@@ -15,51 +11,25 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.//g}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-COMMENT= A LayerII MPEG Audio encoder which supports multi-channel encoding
+COMMENT= MPEG Layer II audio encoder with multi-channel encoding support
USE_GMAKE= yes
-ALL_TARGET=
+ALL_TARGET= #
+MAKE_ARGS= CC="${CC}" OPTIM="${CFLAGS}"
PLIST_SUB= PKGNAMESUFFIX="${PKGNAMESUFFIX}"
-pre-everything::
-.ifndef(WITH_OPTIMIZED_CFLAGS)
- @${ECHO_MSG} '>>>'
- @${ECHO_MSG} '>>> You can enable extra optimizations by defining WITH_OPTIMIZED_CFLAGS'
- @${ECHO_MSG} ">>> For example, 'make WITH_OPTIMIZED_CFLAGS=yes'"
-.endif
- @${ECHO_MSG} '>>>'
-.ifndef(WITH_PROFILED)
- @${ECHO_MSG} ">>> You can enable profiling by defining WITH_PROFILED"
-.endif
+OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
post-patch:
-.ifndef(WITH_OPTIMIZED_CFLAGS)
- @${REINPLACE_CMD} -E \
- -e 's|\$$\(TWEAKS\)||' \
- ${WRKSRC}/Makefile
-.endif
-.ifndef(WITH_PROFILED)
- @${REINPLACE_CMD} -E \
- -e 's|\$$\(PG\)||' \
- ${WRKSRC}/Makefile
-.endif
- @${REINPLACE_CMD} -E \
- -e 's@\$$\((ARCH|OPTIM|WARNINGS)\)@@g' \
- ${WRKSRC}/Makefile
-
-post-configure:
-# C{C,FLAGS} safeness
- @${REINPLACE_CMD} -E \
- -e 's|^(CC[[:space:]]*=).+$$|\1${CC} ${CFLAGS}|' \
- ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|$$(ARCH)||' ${WRKSRC}/Makefile
do-install:
-.ifndef(NOPORTDOCS)
+ ${INSTALL_PROGRAM} ${WRKSRC}/mctoolame ${PREFIX}/bin
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}${PKGNAMESUFFIX}/html
- @${INSTALL_DATA} ${WRKSRC}/html/* ${DOCSDIR}${PKGNAMESUFFIX}/html
+ ${INSTALL_DATA} ${WRKSRC}/html/* ${DOCSDIR}${PKGNAMESUFFIX}/html
.endif
- @${INSTALL_PROGRAM} ${WRKSRC}/mctoolame ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/mctoolame-encoder/pkg-descr b/audio/mctoolame-encoder/pkg-descr
index 20bf70d51e46..539fc0f3f31a 100644
--- a/audio/mctoolame-encoder/pkg-descr
+++ b/audio/mctoolame-encoder/pkg-descr
@@ -1,24 +1,22 @@
-[ excerpt from developer's WWW site ]
+A multi-channel MPEG encoder, using the ISO13818 standard and the dist10
+source code. Multi-channel files may have up to 6 defined channels:
+Left(L), Right(R), Center(C), Left Surround (LS), Right Surround (RS) and
+a Low Frequency Enhancement channel (LFE).
-A multi-channel MPEG encoder, using the ISO13818 standard and the
-dist10 source code. Multi-channel files may have up to 6 defined
-channels: Left(L), Right(R), Center(C), Left Surround (LS), Right
-Surround (RS) and a Low Frequency Enhancement channel (LFE).
+ISO13818 defines 5 multi-channel modes (on top of the normal stereo mode),
+each of these modes may have an optional LFE channel:
-ISO13818 defines 5 multichannel modes (on top of the normal stereo
-mode), each of these modes may have an optional LFE channel:
+ 3/2: L, R, C, LS, RS
+ 3/1: L, R, C, mono surround
+ 2/2: L, R, LS, RS
+ 2/1: L, R, mono surround
+ 3/0: L, R, C
-3/2: L, R, C, LS, RS
-3/1: L, R, C, mono surround
-2/2: L, R, LS, RS
-2/1: L, R, mono surround
-3/0: L, R, C
+The "standard" surround sound encoding of "5.1 channels" is achieved by
+using mode 3/2 plus an LFE channel.
-The "standard" surround sound encoding of "5.1 channels" is achieved
-by using mode 3/2 plus an LFE channel.
-
-A multi-channel MPEG file should decode OK on any MPEG decoder. If
-the decoder doesn't recognize the multi-channel extensions, then
-you'll just get a stereo file containing a down mix of the 5 channels.
+A multi-channel MPEG file should decode OK on any MPEG decoder. If the
+decoder doesn't recognize the multi-channel extensions, then you'll just
+get a stereo file containing a down mix of the 5 channels.
WWW: http://mctoolame.sourceforge.net/