aboutsummaryrefslogtreecommitdiffstats
path: root/audio/moc/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-02-21 20:25:26 +0800
committerpav <pav@FreeBSD.org>2006-02-21 20:25:26 +0800
commitbe4898c6082cfc41f0be1d9a1f179608cc7d3d45 (patch)
treefb459cf2e847365537f11957fd514097159ca957 /audio/moc/Makefile
parent8e6c486361b6ab25c60fc9cf4323686124e2416d (diff)
downloadfreebsd-ports-gnome-be4898c6082cfc41f0be1d9a1f179608cc7d3d45.tar.gz
freebsd-ports-gnome-be4898c6082cfc41f0be1d9a1f179608cc7d3d45.tar.zst
freebsd-ports-gnome-be4898c6082cfc41f0be1d9a1f179608cc7d3d45.zip
- Update to 2.4.0
Submitted by: maintainer
Diffstat (limited to 'audio/moc/Makefile')
-rw-r--r--audio/moc/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/audio/moc/Makefile b/audio/moc/Makefile
index 43f1ae7cb797..f84ae1bb9c66 100644
--- a/audio/moc/Makefile
+++ b/audio/moc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= moc
-PORTVERSION= 2.3.3
+PORTVERSION= 2.4.0
CATEGORIES= audio
MASTER_SITES= ftp://ftp.daper.net/pub/soft/moc/stable/
@@ -26,6 +26,7 @@ LDFLAGS= -L${LOCALBASE}/lib
OPTIONS= JACK "JACK support" off \
MP3 "MP3 support" on \
+ FFMPEG "FFMPEG support" off \
MUSEPACK "Musepack (mpc) support" off \
VORBIS "Ogg Vorbis support" on \
FLAC "FLAC support" off \
@@ -36,8 +37,8 @@ OPTIONS= JACK "JACK support" off \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 400010
-LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+.if ${OSVERSION} < 500000
+IGNORE= requires C99 string functions in libc
.endif
.if defined(WITH_JACK)
@@ -64,7 +65,7 @@ CONFIGURE_ARGS+= --without-musepack
.if defined(WITH_VORBIS)
LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
-PLIST_FILES+= lib/moc/decoder_plugins/libogg_decoder.so
+PLIST_FILES+= lib/moc/decoder_plugins/libvorbis_decoder.so
.else
CONFIGURE_ARGS+= --without-ogg
.endif
@@ -76,6 +77,12 @@ PLIST_FILES+= lib/moc/decoder_plugins/libflac_decoder.so
CONFIGURE_ARGS+= --without-flac
.endif
+.if defined(WITH_FFMPEG)
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+.else
+CONFIGURE_ARGS+= --without-ffmpeg
+.endif
+
.if defined(WITH_SNDFILE)
LIB_DEPENDS+= sndfile.1:${PORTSDIR}/audio/libsndfile
PLIST_FILES+= lib/moc/decoder_plugins/libsndfile_formats_decoder.so