aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mp3burn
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-20 06:02:41 +0800
committerpav <pav@FreeBSD.org>2003-12-20 06:02:41 +0800
commit3e265ab8a801e7d3f667731bc4012931ba17d4d4 (patch)
tree5a86ff66025cfb9a544a46f8aded3d46f33f1f60 /audio/mp3burn
parent75456e06df0a5a4d2cbe3c38d9a53cb6a339d725 (diff)
downloadfreebsd-ports-gnome-3e265ab8a801e7d3f667731bc4012931ba17d4d4.tar.gz
freebsd-ports-gnome-3e265ab8a801e7d3f667731bc4012931ba17d4d4.tar.zst
freebsd-ports-gnome-3e265ab8a801e7d3f667731bc4012931ba17d4d4.zip
Add mp3burn, a commandline tool for burning audio CDs from mp3 files
PR: ports/60404 Submitted by: vinc <vinc@FreeBSD-fr.org>
Diffstat (limited to 'audio/mp3burn')
-rw-r--r--audio/mp3burn/Makefile33
-rw-r--r--audio/mp3burn/distinfo1
-rw-r--r--audio/mp3burn/pkg-descr4
-rw-r--r--audio/mp3burn/pkg-plist1
4 files changed, 39 insertions, 0 deletions
diff --git a/audio/mp3burn/Makefile b/audio/mp3burn/Makefile
new file mode 100644
index 000000000000..d98b048fbbce
--- /dev/null
+++ b/audio/mp3burn/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mp3burn
+# Date created: 17th December 2003
+# Whom: Vincent Tantardini <vinc@FreeBSD-fr.org>
+#
+# $FreeBSD$
+
+PORTNAME= mp3burn
+PORTVERSION= 0.1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Command line tool for making audio CDs from mp3s
+
+RUN_DEPENDS= cdrecord:${PORTSDIR}/sysutils/cdrtools \
+ mpg123:${PORTSDIR}/audio/mpg123 \
+ ${SITE_PERL}/MPEG/MP3Info.pm:${PORTSDIR}/audio/p5-MP3-Info
+
+USE_PERL5= yes
+NO_BUILD= yes
+USE_REINPLACE= yes
+MAN1= mp3burn.1
+MANCOMPRESSED= no
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/mp3burn
+
+do-install:
+ @${CP} ${WRKSRC}/mp3burn ${PREFIX}/bin
+ @${CP} ${WRKSRC}/mp3burn.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/audio/mp3burn/distinfo b/audio/mp3burn/distinfo
new file mode 100644
index 000000000000..cc758450a899
--- /dev/null
+++ b/audio/mp3burn/distinfo
@@ -0,0 +1 @@
+MD5 (mp3burn-0.1.tar.gz) = 3e9a0d5d676da43445c03949098c3b77
diff --git a/audio/mp3burn/pkg-descr b/audio/mp3burn/pkg-descr
new file mode 100644
index 000000000000..18f6b5256043
--- /dev/null
+++ b/audio/mp3burn/pkg-descr
@@ -0,0 +1,4 @@
+mp3burn is a simple command line tool for making audio CDs from mp3s
+without filling up your disk with .wav files.
+
+WWW: http://mp3burn.sourceforge.net/
diff --git a/audio/mp3burn/pkg-plist b/audio/mp3burn/pkg-plist
new file mode 100644
index 000000000000..f96e0aaa0b0d
--- /dev/null
+++ b/audio/mp3burn/pkg-plist
@@ -0,0 +1 @@
+bin/mp3burn