aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mp3riot
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-11-18 05:18:53 +0800
committerpav <pav@FreeBSD.org>2003-11-18 05:18:53 +0800
commitb787355d7a394df7c0d40d14af669569cb61f084 (patch)
tree57c56220c7a1372de897ceb996e55d4bb5e5aafd /audio/mp3riot
parentb2e61a564934ac7fcb7304509ee014cde567ca0e (diff)
downloadfreebsd-ports-gnome-b787355d7a394df7c0d40d14af669569cb61f084.tar.gz
freebsd-ports-gnome-b787355d7a394df7c0d40d14af669569cb61f084.tar.zst
freebsd-ports-gnome-b787355d7a394df7c0d40d14af669569cb61f084.zip
mp3riot is a command line perl script to generate listings of mp3 files.
It can output HTML, XML, m3u or pls playlists. PR: ports/55595 Submitted by: Francisco Gomez <francisco@gomezmarin.com> Approved by: adamw (mentor)
Diffstat (limited to 'audio/mp3riot')
-rw-r--r--audio/mp3riot/Makefile39
-rw-r--r--audio/mp3riot/distinfo1
-rw-r--r--audio/mp3riot/pkg-descr12
-rw-r--r--audio/mp3riot/pkg-plist1
4 files changed, 53 insertions, 0 deletions
diff --git a/audio/mp3riot/Makefile b/audio/mp3riot/Makefile
new file mode 100644
index 000000000000..db27da76d829
--- /dev/null
+++ b/audio/mp3riot/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: mp3riot
+# Date created: 29 July 2003
+# Whom: Francisco Gomez <francisco@gomezmarin.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3riot
+PORTVERSION= 1.1
+CATEGORIES= audio
+MASTER_SITES= http://www.linuxsecure.de/f2html/
+
+MAINTAINER= francisco@gomezmarin.com
+COMMENT= Mp3riot creates mp3 playlists, HTML files, etc
+
+RUN_DEPENDS= ${SITE_PERL}/MP3/Info.pm:${PORTSDIR}/audio/p5-MP3-Info
+
+NO_BUILD= yes
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+
+PORTDOCS= example.unix groupfile CHANGELOG MANUAL mp3table.sql README repl.dat TODO utf.dat
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+RUN_DEPENDS+= ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long
+.endif
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/mp3riot ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for item in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${item} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/mp3riot/distinfo b/audio/mp3riot/distinfo
new file mode 100644
index 000000000000..94d033e1c0a9
--- /dev/null
+++ b/audio/mp3riot/distinfo
@@ -0,0 +1 @@
+MD5 (mp3riot-1.1.zip) = 934d2ea05059b1945bfa062e0dd43eeb
diff --git a/audio/mp3riot/pkg-descr b/audio/mp3riot/pkg-descr
new file mode 100644
index 000000000000..eec350e1ee1f
--- /dev/null
+++ b/audio/mp3riot/pkg-descr
@@ -0,0 +1,12 @@
+mp3riot (formerly known as f2html.pl) is a command line utility
+that searches recursively through directories, builds a file list
+(with additional file information), and generates HTML files,
+playlists, etc. The output can be controlled, links can be corrected,
+and more. The script is mainly desigend to create Web pages,
+playlists, and databases for MP3 and Ogg files, but can also used for
+other purposes.
+
+WWW: http://www.linuxsecure.de/index.php?action=55
+
+- Francisco -
+francisco@gomezmarin.com
diff --git a/audio/mp3riot/pkg-plist b/audio/mp3riot/pkg-plist
new file mode 100644
index 000000000000..16443aea5d8a
--- /dev/null
+++ b/audio/mp3riot/pkg-plist
@@ -0,0 +1 @@
+bin/mp3riot