aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mp3splt
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-06-14 16:16:16 +0800
committeradamw <adamw@FreeBSD.org>2003-06-14 16:16:16 +0800
commitfdee90fe500cf1e2f9b372060d39fdd9bf5b86a4 (patch)
tree3b8c7396f5982c1108172bdf5ca06cfd6dd27217 /audio/mp3splt
parent472ba62a0f046534708911f95d495e84010d4b72 (diff)
downloadfreebsd-ports-gnome-fdee90fe500cf1e2f9b372060d39fdd9bf5b86a4.tar.gz
freebsd-ports-gnome-fdee90fe500cf1e2f9b372060d39fdd9bf5b86a4.tar.zst
freebsd-ports-gnome-fdee90fe500cf1e2f9b372060d39fdd9bf5b86a4.zip
Add mp3splt.
mp3splt is a nice utility to split large mp3/ogg files via cue-sheet PR: ports/52899 Submitted by: Ulrich Spoerlein <q@uni.de>
Diffstat (limited to 'audio/mp3splt')
-rw-r--r--audio/mp3splt/Makefile30
-rw-r--r--audio/mp3splt/distinfo1
-rw-r--r--audio/mp3splt/pkg-descr10
-rw-r--r--audio/mp3splt/pkg-plist2
4 files changed, 43 insertions, 0 deletions
diff --git a/audio/mp3splt/Makefile b/audio/mp3splt/Makefile
new file mode 100644
index 000000000000..233cb0120f6e
--- /dev/null
+++ b/audio/mp3splt/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: audio/mp3splt
+# Date created: 30.05.2003
+# Whom: Ulrich Spoerlein <q@uni.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3splt
+PORTVERSION= 1.8
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= q@uni.de
+COMMENT= Utility to split mp3 and ogg files (via CUE sheets)
+
+LIB_DEPENDS= mad.1:${PORTSDIR}/audio/mad \
+ vorbis.2:${PORTSDIR}/audio/libvorbis \
+ ogg.4:${PORTSDIR}/audio/libogg
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN1= mp3splt.1
+
+.include <bsd.port.mk>
diff --git a/audio/mp3splt/distinfo b/audio/mp3splt/distinfo
new file mode 100644
index 000000000000..00ddc9fde361
--- /dev/null
+++ b/audio/mp3splt/distinfo
@@ -0,0 +1 @@
+MD5 (mp3splt-1.8-src.tar.gz) = c3830bc7f98d344ad371a5e1a7acc91e
diff --git a/audio/mp3splt/pkg-descr b/audio/mp3splt/pkg-descr
new file mode 100644
index 000000000000..9e46155d2c4a
--- /dev/null
+++ b/audio/mp3splt/pkg-descr
@@ -0,0 +1,10 @@
+Mp3Splt is a command line utility to split mp3 and ogg files selecting a begin
+and an end time position, without decoding. It's very useful to split large
+mp3/ogg to make smaller files or to split entire albums to obtain original
+tracks. If you want to split an album, you can select split points and
+filenames manually or you can get them automatically from CDDB (internet or a
+local file) or from .cue files. Otherwise if you have a file created either
+with Mp3Wrap or AlbumWrap you can extract tracks just in few seconds. Supports
+VBR mp3.
+
+WWW: http://mp3splt.sourceforge.net/
diff --git a/audio/mp3splt/pkg-plist b/audio/mp3splt/pkg-plist
new file mode 100644
index 000000000000..ac95acbe231d
--- /dev/null
+++ b/audio/mp3splt/pkg-plist
@@ -0,0 +1,2 @@
+bin/mp3splt
+bin/oggsplt