aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mpg123.el
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-03-03 21:20:08 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-03-03 21:20:08 +0800
commit0d6e5881df95bbd35d5536c35355b10953edb7a0 (patch)
treea5ede282e04c4b124618532f887f25ecbc8c21c6 /audio/mpg123.el
parent41012809026915e9ce007b074316515fb4b6abd4 (diff)
downloadfreebsd-ports-gnome-0d6e5881df95bbd35d5536c35355b10953edb7a0.tar.gz
freebsd-ports-gnome-0d6e5881df95bbd35d5536c35355b10953edb7a0.tar.zst
freebsd-ports-gnome-0d6e5881df95bbd35d5536c35355b10953edb7a0.zip
Support staging
Diffstat (limited to 'audio/mpg123.el')
-rw-r--r--audio/mpg123.el/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/audio/mpg123.el/Makefile b/audio/mpg123.el/Makefile
index fa8bc5637691..134bb55325e0 100644
--- a/audio/mpg123.el/Makefile
+++ b/audio/mpg123.el/Makefile
@@ -23,16 +23,12 @@ XELISPDIR= ${PREFIX}/lib/xemacs/site-lisp
FETCH_ARGS= -AR
FETCH_BEFORE_ARGS= -o mpg123el.cgi?${PORTVERSION}
-NO_STAGE= yes
do-install:
- ${MKDIR} ${ELISPDIR}
- ${INSTALL_DATA} ${DISTDIR}/mpg123el.cgi?${PORTVERSION} ${ELISPDIR}/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${ELISPDIR}
+ ${INSTALL_DATA} ${DISTDIR}/mpg123el.cgi?${PORTVERSION} ${STAGEDIR}${ELISPDIR}/${PORTNAME}
# For XEmacs
- ${MKDIR} ${XELISPDIR}
- ${LN} -sf ${ELISPDIR}/${PORTNAME} ${XELISPDIR}/${PORTNAME}
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${XELISPDIR}
+ ${LN} -sf ${PORTNAME} ${STAGEDIR}${XELISPDIR}/${PORTNAME}
.include <bsd.port.mk>