aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mpg123/Makefile
diff options
context:
space:
mode:
authorgreen <green@FreeBSD.org>2000-01-28 15:50:12 +0800
committergreen <green@FreeBSD.org>2000-01-28 15:50:12 +0800
commit531b757e3f7eca9a9e884503d21c8d028c6e2713 (patch)
treeb9a485b56d4012397748610c9fe59eda3011a6b9 /audio/mpg123/Makefile
parent0a596c35c96f34fda453e2882ab7d03b017360ac (diff)
downloadfreebsd-ports-gnome-531b757e3f7eca9a9e884503d21c8d028c6e2713.tar.gz
freebsd-ports-gnome-531b757e3f7eca9a9e884503d21c8d028c6e2713.tar.zst
freebsd-ports-gnome-531b757e3f7eca9a9e884503d21c8d028c6e2713.zip
Enable 3DNow! support. You can set OPT_ARCH=3dnow to get an mpg123 with
3DNow! support, rather than teh default i586 support. Approved by: jkoshy
Diffstat (limited to 'audio/mpg123/Makefile')
-rw-r--r--audio/mpg123/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/audio/mpg123/Makefile b/audio/mpg123/Makefile
index ab9c60e71265..a26896eca5dc 100644
--- a/audio/mpg123/Makefile
+++ b/audio/mpg123/Makefile
@@ -46,11 +46,12 @@ pre-configure:
@${ECHO_MSG} "+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++"
.endif
.if $(MACHINE_ARCH) == "i386"
-.if !defined(OPT_ARCH) || (($(OPT_ARCH) != "i486") && ($(OPT_ARCH) != "i586"))
+.if !defined(OPT_ARCH) || (($(OPT_ARCH) != "i486") && ($(OPT_ARCH) != "i586") \
+ && ($(OPT_ARCH) != "3dnow"))
@${ECHO_MSG} "+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++"
@${ECHO_MSG} "Note: you can set OPT_ARCH to optimize for your hardware. (Eg:- make OPT_ARCH=i486)"
.if $(PORTOBJFORMAT) == "elf"
- @${ECHO_MSG} "Valid values are: i486, i586"
+ @${ECHO_MSG} "Valid values are: i486, i586, 3dnow"
.else
@${ECHO_MSG} "Valid values are: i486"
.endif