aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mpg321
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2010-06-07 04:39:21 +0800
committernaddy <naddy@FreeBSD.org>2010-06-07 04:39:21 +0800
commita7e23ef2423b94523671d838b70763ecfea3ca60 (patch)
tree3d3fdf131c6f5d30a25430d16a62f0d82e33445f /audio/mpg321
parent14d2f864caf57bceba3f0ac72ea827fafd27743d (diff)
downloadfreebsd-ports-gnome-a7e23ef2423b94523671d838b70763ecfea3ca60.tar.gz
freebsd-ports-gnome-a7e23ef2423b94523671d838b70763ecfea3ca60.tar.zst
freebsd-ports-gnome-a7e23ef2423b94523671d838b70763ecfea3ca60.zip
Bump PORTREVISION after libao update and handle API incompatibility.
Diffstat (limited to 'audio/mpg321')
-rw-r--r--audio/mpg321/Makefile4
-rw-r--r--audio/mpg321/files/patch-ao.c13
2 files changed, 15 insertions, 2 deletions
diff --git a/audio/mpg321/Makefile b/audio/mpg321/Makefile
index 5af3d7da85ab..f8a1e70f04da 100644
--- a/audio/mpg321/Makefile
+++ b/audio/mpg321/Makefile
@@ -7,14 +7,14 @@
PORTNAME= mpg321
PORTVERSION= 0.2.10
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= audio
MASTER_SITES= SF
MAINTAINER= naddy@FreeBSD.org
COMMENT= A free command-line mp3 player, compatible with mpg123
-LIB_DEPENDS= ao.3:${PORTSDIR}/audio/libao \
+LIB_DEPENDS= ao.4:${PORTSDIR}/audio/libao \
id3tag.0:${PORTSDIR}/audio/libid3tag \
mad.2:${PORTSDIR}/audio/libmad
diff --git a/audio/mpg321/files/patch-ao.c b/audio/mpg321/files/patch-ao.c
new file mode 100644
index 000000000000..9691820d0e17
--- /dev/null
+++ b/audio/mpg321/files/patch-ao.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- ao.c.orig
++++ ao.c
+@@ -229,6 +229,7 @@
+ and restore it afterwards */
+ signal(SIGINT, SIG_DFL);
+
++ memset(&format, 0, sizeof(format));
+ format.bits = 16;
+ format.rate = header->samplerate;
+ format.channels = (options.opt & MPG321_FORCE_STEREO) ? 2 : MAD_NCHANNELS(header);