aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mpiosh
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-04-08 06:00:12 +0800
committerstas <stas@FreeBSD.org>2009-04-08 06:00:12 +0800
commit9308aba34461cbafa0c0cf26f313e05546ad012d (patch)
tree4fcd9eaef8f57602235705186b36f6a80992a5bb /audio/mpiosh
parent3d2b0a6dce41607b6a44b8ecbdbe764eacdd6c73 (diff)
downloadfreebsd-ports-gnome-9308aba34461cbafa0c0cf26f313e05546ad012d.tar.gz
freebsd-ports-gnome-9308aba34461cbafa0c0cf26f313e05546ad012d.tar.zst
freebsd-ports-gnome-9308aba34461cbafa0c0cf26f313e05546ad012d.zip
- Fix package building after switching to 'configure' rebuilding. [1]
- Do not install .la and static library files. Reported by: erwin [1]
Diffstat (limited to 'audio/mpiosh')
-rw-r--r--audio/mpiosh/Makefile17
-rw-r--r--audio/mpiosh/files/extra-patch-configure.in25
-rw-r--r--audio/mpiosh/files/patch-Makefile.am7
-rw-r--r--audio/mpiosh/files/patch-Makefile.in11
-rw-r--r--audio/mpiosh/files/patch-configure11
-rw-r--r--audio/mpiosh/files/patch-configure.in17
-rw-r--r--audio/mpiosh/files/patch-libmpio_Makefile.am10
-rw-r--r--audio/mpiosh/files/patch-mpiosh-Makefile.in11
-rw-r--r--audio/mpiosh/files/patch-mpiosh_Makefile.am18
-rw-r--r--audio/mpiosh/pkg-plist2
10 files changed, 73 insertions, 56 deletions
diff --git a/audio/mpiosh/Makefile b/audio/mpiosh/Makefile
index 8d62ba3a0585..4b1bdff3f0f4 100644
--- a/audio/mpiosh/Makefile
+++ b/audio/mpiosh/Makefile
@@ -14,12 +14,14 @@ DISTNAME= mpio-${PORTVERSION:S|.p|_pre|}
MAINTAINER= ports@FreeBSD.org
COMMENT= Digit@lway MPIO MP3 player tool
-USE_AUTOTOOLS= libtool:15
USE_ICONV= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+USE_AUTOTOOLS= aclocal:110 automake:110 autoconf:262 libtool:15
+ACLOCAL_ARGS= -I . -I ${LOCALBASE}/share/aclocal
+AUTOMAKE_ARGS= --add-missing
+CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib -liconv"
.include <bsd.port.pre.mk>
@@ -27,9 +29,18 @@ CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
.else
EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure.in
-USE_AUTOTOOLS= autoconf:262
.endif
+patch-autotools:
+ ${DO_NADA}
+
+#
+# Get rid of .la and static library files
+#
+post-configure:
+ @${REINPLACE_CMD} -E -e \
+ '/Install the pseudo-library/,/staticlibs=/s,^,#,' ${WRKSRC}/libtool
+
post-patch:
.if ${OSVERSION} >= 800069
${RM} -f ${WRKSRC}/configure
diff --git a/audio/mpiosh/files/extra-patch-configure.in b/audio/mpiosh/files/extra-patch-configure.in
index 22deee13d378..280374f08f68 100644
--- a/audio/mpiosh/files/extra-patch-configure.in
+++ b/audio/mpiosh/files/extra-patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig 2004-05-30 05:45:55.000000000 +0400
-+++ configure.in 2009-03-07 01:43:55.000000000 +0300
-@@ -60,34 +60,18 @@
+--- configure.in.orig 2009-04-08 01:50:59.000000000 +0400
++++ configure.in 2009-04-08 01:52:14.000000000 +0400
+@@ -60,23 +60,17 @@
dnl -- check for libusb
dnl -- this is stolen from libgphoto2
@@ -8,8 +8,8 @@
-if test -n "${LIBUSB_CONFIG}"; then
- CPPFLAGS_save="$CPPFLAGS"
- CPPFLAGS="$CPPFLAGS `$LIBUSB_CONFIG --cflags`"
-+CPPFLAGS_save="$CPPFLAGS"
- AC_CHECK_HEADER(usb.h,[
+- AC_CHECK_HEADER(usb.h,[
++AC_CHECK_HEADER(usb.h,[
LDFLAGS_orig="$LDFLAGS"
- LDFLAGS="`$LIBUSB_CONFIG --libs`"
+ LDFLAGS="-lusb"
@@ -25,17 +25,6 @@
LDFLAGS="$LDFLAGS_orig"])
CPPFLAGS="$CPPFLAGS_save"
-fi
--
-- # This 'test' call uses non-standard syntax and will fail on most
-- # systems, but it's just informational so any warning can be ignored.
--if test "$LIBUSB_VER" \< "0.1.7"; then
-- AC_MSG_WARN([
--*** You need at least version 0.1.7 of the libusb library for USB support
--*** http://sourceforge.net/projects/libusb/
--*** If you cannot find the appropriate version, try CVS
-- ])
-- exit 1
--fi
- case "$usb_msg" in
- yes*) AC_DEFINE(HAVE_USB,1,[Whether you have USB support enabled]);;
+ # This 'test' call uses non-standard syntax and will fail on most
+ # systems, but it's just informational so any warning can be ignored.
diff --git a/audio/mpiosh/files/patch-Makefile.am b/audio/mpiosh/files/patch-Makefile.am
new file mode 100644
index 000000000000..de8196510db1
--- /dev/null
+++ b/audio/mpiosh/files/patch-Makefile.am
@@ -0,0 +1,7 @@
+--- Makefile.am.orig 2009-04-08 01:40:10.000000000 +0400
++++ Makefile.am 2009-04-08 01:40:14.000000000 +0400
+@@ -1,3 +1,3 @@
+-SUBDIRS=@MPIO_KERNEL@ libmpio mpiosh etc tools hotplug
++SUBDIRS=@MPIO_KERNEL@ libmpio mpiosh etc tools
+
+ EXTRA_DIST=mpio.spec
diff --git a/audio/mpiosh/files/patch-Makefile.in b/audio/mpiosh/files/patch-Makefile.in
deleted file mode 100644
index a8f9bb892916..000000000000
--- a/audio/mpiosh/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Mon May 31 09:13:58 2004
-+++ Makefile.in Mon May 31 09:14:08 2004
-@@ -184,7 +184,7 @@
- target_cpu = @target_cpu@
- target_os = @target_os@
- target_vendor = @target_vendor@
--SUBDIRS = @MPIO_KERNEL@ libmpio mpiosh etc tools hotplug
-+SUBDIRS = @MPIO_KERNEL@ libmpio mpiosh etc tools
- EXTRA_DIST = mpio.spec
- all: all-recursive
-
diff --git a/audio/mpiosh/files/patch-configure b/audio/mpiosh/files/patch-configure
deleted file mode 100644
index ad4dd6448656..000000000000
--- a/audio/mpiosh/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Sun May 30 05:47:49 2004
-+++ configure Sat Jul 23 18:09:22 2005
-@@ -19999,7 +19999,7 @@
-
- # This 'test' call uses non-standard syntax and will fail on most
- # systems, but it's just informational so any warning can be ignored.
--if test "$LIBUSB_VER" \< "0.1.7"; then
-+if test "$LIBUSB_VER" \< "0.1.10"; then
- { echo "$as_me:$LINENO: WARNING:
- *** You need at least version 0.1.7 of the libusb library for USB support
- *** http://sourceforge.net/projects/libusb/
diff --git a/audio/mpiosh/files/patch-configure.in b/audio/mpiosh/files/patch-configure.in
new file mode 100644
index 000000000000..3200ddfdb2f6
--- /dev/null
+++ b/audio/mpiosh/files/patch-configure.in
@@ -0,0 +1,17 @@
+--- configure.in.orig 2009-04-08 01:37:33.000000000 +0400
++++ configure.in 2009-04-08 01:37:43.000000000 +0400
+@@ -80,14 +80,6 @@
+
+ # This 'test' call uses non-standard syntax and will fail on most
+ # systems, but it's just informational so any warning can be ignored.
+-if test "$LIBUSB_VER" \< "0.1.7"; then
+- AC_MSG_WARN([
+-*** You need at least version 0.1.7 of the libusb library for USB support
+-*** http://sourceforge.net/projects/libusb/
+-*** If you cannot find the appropriate version, try CVS
+- ])
+- exit 1
+-fi
+
+ case "$usb_msg" in
+ yes*) AC_DEFINE(HAVE_USB,1,[Whether you have USB support enabled]);;
diff --git a/audio/mpiosh/files/patch-libmpio_Makefile.am b/audio/mpiosh/files/patch-libmpio_Makefile.am
new file mode 100644
index 000000000000..2c15db42bb4f
--- /dev/null
+++ b/audio/mpiosh/files/patch-libmpio_Makefile.am
@@ -0,0 +1,10 @@
+--- libmpio/Makefile.am.orig 2009-04-08 01:38:43.000000000 +0400
++++ libmpio/Makefile.am 2009-04-08 01:38:48.000000000 +0400
+@@ -1,6 +1,6 @@
+ INCLUDES=@MPLIB_INCLUDE@
+ AM_CFLAGS=@MPLIB_CFLAGS@ @USB_CFLAGS@
+-AM_LDFLAGS=-version-info 1:0:0 @USB_LIBS@
++AM_LDFLAGS=-version-info 1 @USB_LIBS@
+
+ lib_LTLIBRARIES=libmpio.la
+
diff --git a/audio/mpiosh/files/patch-mpiosh-Makefile.in b/audio/mpiosh/files/patch-mpiosh-Makefile.in
deleted file mode 100644
index 169ec6d64737..000000000000
--- a/audio/mpiosh/files/patch-mpiosh-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- mpiosh/Makefile.in.orig Mon May 31 09:19:32 2004
-+++ mpiosh/Makefile.in Mon May 31 09:20:36 2004
-@@ -116,7 +116,7 @@
- KERNEL_INCLUDE = @KERNEL_INCLUDE@
- LDFLAGS = @LDFLAGS@
- LIBOBJS = @LIBOBJS@
--LIBS = @LIBS@
-+LIBS = @LIBS@ -liconv
- LIBTOOL = @LIBTOOL@
- LIBUSB_CONFIG = @LIBUSB_CONFIG@
- LN_S = @LN_S@
diff --git a/audio/mpiosh/files/patch-mpiosh_Makefile.am b/audio/mpiosh/files/patch-mpiosh_Makefile.am
new file mode 100644
index 000000000000..b994b24b822a
--- /dev/null
+++ b/audio/mpiosh/files/patch-mpiosh_Makefile.am
@@ -0,0 +1,18 @@
+--- mpiosh/Makefile.am.orig 2009-04-08 01:39:27.000000000 +0400
++++ mpiosh/Makefile.am 2009-04-08 01:39:41.000000000 +0400
+@@ -12,7 +12,7 @@
+
+ AM_CFLAGS=-DSYSCONFDIR=\"@sysconfdir@\"
+
+-mpiosh_LDADD=../libmpio/libmpio.la -lreadline -lncurses
++mpiosh_LDADD=../libmpio/libmpio.la -lreadline -lncurses -liconv
+
+ noinst_HEADERS = mpiosh.h \
+ callback.h \
+@@ -20,4 +20,4 @@
+ command.h \
+ global.h \
+ cfgio.h \
+- config.h
+\ No newline at end of file
++ config.h
diff --git a/audio/mpiosh/pkg-plist b/audio/mpiosh/pkg-plist
index 1e2da3ee2af4..7531bd270a5e 100644
--- a/audio/mpiosh/pkg-plist
+++ b/audio/mpiosh/pkg-plist
@@ -1,8 +1,6 @@
bin/mpiologo
bin/mpiosh
etc/mpio/mpioshrc
-lib/libmpio.a
-lib/libmpio.la
lib/libmpio.so
lib/libmpio.so.1
include/mpio/defs.h