aboutsummaryrefslogtreecommitdiffstats
path: root/audio/muine
diff options
context:
space:
mode:
authorromain <romain@FreeBSD.org>2010-05-14 18:28:17 +0800
committerromain <romain@FreeBSD.org>2010-05-14 18:28:17 +0800
commit7a8c97d834d33e4c91c5527ccc7127d769b0cac5 (patch)
treef8761cc4d23d1023ed2ad962d99d77d942989d65 /audio/muine
parent904975f4ac189eafb19a43632b991c3447b0d6f6 (diff)
downloadfreebsd-ports-gnome-7a8c97d834d33e4c91c5527ccc7127d769b0cac5.tar.gz
freebsd-ports-gnome-7a8c97d834d33e4c91c5527ccc7127d769b0cac5.tar.zst
freebsd-ports-gnome-7a8c97d834d33e4c91c5527ccc7127d769b0cac5.zip
Fix build after GNOME update.
Submitted by: pointyhat
Diffstat (limited to 'audio/muine')
-rw-r--r--audio/muine/Makefile2
-rw-r--r--audio/muine/files/patch-libmuine_rb-cell-renderer-pixbuf.c22
2 files changed, 23 insertions, 1 deletions
diff --git a/audio/muine/Makefile b/audio/muine/Makefile
index e587284ce004..c61aa92d29ab 100644
--- a/audio/muine/Makefile
+++ b/audio/muine/Makefile
@@ -8,7 +8,7 @@
PORTNAME= muine
PORTVERSION= 0.8.11
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio gnome
MASTER_SITES= GNOME
diff --git a/audio/muine/files/patch-libmuine_rb-cell-renderer-pixbuf.c b/audio/muine/files/patch-libmuine_rb-cell-renderer-pixbuf.c
new file mode 100644
index 000000000000..fb5ec48b3769
--- /dev/null
+++ b/audio/muine/files/patch-libmuine_rb-cell-renderer-pixbuf.c
@@ -0,0 +1,22 @@
+
+$FreeBSD$
+
+--- libmuine/rb-cell-renderer-pixbuf.c.orig
++++ libmuine/rb-cell-renderer-pixbuf.c
+@@ -295,14 +295,14 @@
+
+ if ((flags & GTK_CELL_RENDERER_SELECTED) == GTK_CELL_RENDERER_SELECTED)
+ {
+- if (GTK_WIDGET_HAS_FOCUS (widget))
++ if (gtk_widget_has_focus (widget))
+ state = GTK_STATE_SELECTED;
+ else
+ state = GTK_STATE_ACTIVE;
+ }
+ else
+ {
+- if (GTK_WIDGET_STATE (widget) == GTK_STATE_INSENSITIVE)
++ if (GTK_OBJECT_FLAGS (widget) == GTK_STATE_INSENSITIVE)
+ state = GTK_STATE_INSENSITIVE;
+ else
+ state = GTK_STATE_NORMAL;