aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mumble
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2018-01-03 04:30:39 +0800
committerfeld <feld@FreeBSD.org>2018-01-03 04:30:39 +0800
commitd0b908d51df237c73f7c0b89ed1a8e9e5dacce20 (patch)
treee792fe20d92da81337c540c05d2b0132dce9663c /audio/mumble
parent88f202ff631de879574d844ea78521048db55e79 (diff)
downloadfreebsd-ports-gnome-d0b908d51df237c73f7c0b89ed1a8e9e5dacce20.tar.gz
freebsd-ports-gnome-d0b908d51df237c73f7c0b89ed1a8e9e5dacce20.tar.zst
freebsd-ports-gnome-d0b908d51df237c73f7c0b89ed1a8e9e5dacce20.zip
audio/mumble: add patch to fix build against boost 1.66
PR: 224086
Diffstat (limited to 'audio/mumble')
-rw-r--r--audio/mumble/Makefile2
-rw-r--r--audio/mumble/audio/mumble/files/extrapatch-fix-build-boost-1.6626
2 files changed, 27 insertions, 1 deletions
diff --git a/audio/mumble/Makefile b/audio/mumble/Makefile
index 80d20517f100..4a194c6a392e 100644
--- a/audio/mumble/Makefile
+++ b/audio/mumble/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mumble
PORTVERSION= 1.2.19
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MAINTAINER= feld@FreeBSD.org
diff --git a/audio/mumble/audio/mumble/files/extrapatch-fix-build-boost-1.66 b/audio/mumble/audio/mumble/files/extrapatch-fix-build-boost-1.66
new file mode 100644
index 000000000000..2efbfc26df7d
--- /dev/null
+++ b/audio/mumble/audio/mumble/files/extrapatch-fix-build-boost-1.66
@@ -0,0 +1,26 @@
+diff --git a/src/mumble/AudioOutput.cpp b/src/mumble/AudioOutput.cpp
+index cbe0c0e2b..7a0a5e2ab 100644
+--- a/src/mumble/AudioOutput.cpp
++++ b/src/mumble/AudioOutput.cpp
+@@ -437,7 +437,7 @@ bool AudioOutput::mix(void *outbuff, unsigned int nsamp) {
+ top[2] = 0.0f;
+ }
+
+- if (std::abs<float>(front[0] * top[0] + front[1] * top[1] + front[2] * top[2]) > 0.01f) {
++ if (std::abs(front[0] * top[0] + front[1] * top[1] + front[2] * top[2]) > 0.01f) {
+ // Not perpendicular. Assume Y up and rotate 90 degrees.
+
+ float azimuth = 0.0f;
+diff --git a/src/mumble/mumble_pch.hpp b/src/mumble/mumble_pch.hpp
+index ba87eab3b..dac5ba629 100644
+--- a/src/mumble/mumble_pch.hpp
++++ b/src/mumble/mumble_pch.hpp
+@@ -37,6 +37,8 @@
+ #include <QtSql/QtSql>
+ #include <QtXml/QtXml>
+
++#include <cmath>
++
+ #ifdef Q_OS_WIN
+ #include <windows.h>
+ #define ENABLE_SNDFILE_WINDOWS_PROTOTYPES 1