aboutsummaryrefslogtreecommitdiffstats
path: root/audio/muse/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-12-22 19:56:46 +0800
committerkrion <krion@FreeBSD.org>2003-12-22 19:56:46 +0800
commit62d4b5fad2c0a5739777f0cabb454ccae1196d59 (patch)
treebd8c6b4eafd9bc4ec936a66997e46f74c32cfaae /audio/muse/Makefile
parenta42c0e152115266e7d31143fbdfbae21b1108a79 (diff)
downloadfreebsd-ports-gnome-62d4b5fad2c0a5739777f0cabb454ccae1196d59.tar.gz
freebsd-ports-gnome-62d4b5fad2c0a5739777f0cabb454ccae1196d59.tar.zst
freebsd-ports-gnome-62d4b5fad2c0a5739777f0cabb454ccae1196d59.zip
- Add WITHOUT_X11 knob
PR: 60459 Submitted by: Ports Fury
Diffstat (limited to 'audio/muse/Makefile')
-rw-r--r--audio/muse/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/audio/muse/Makefile b/audio/muse/Makefile
index 607f1ccf97f1..9988a792960e 100644
--- a/audio/muse/Makefile
+++ b/audio/muse/Makefile
@@ -23,17 +23,23 @@ LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
-USE_GNOME= gtk12
+USE_GNOME= gnometarget
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-debug
MAN1= muse.1
-CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+.if defined(WITHOUT_X11)
+PKGNAMESUFFIX= -nox11
+CONFIGURE_ARGS+= --without-x --with-rubik
+.else
+USE_GNOME+= gtk12
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|^CFLAGS=.*$$|CFLAGS="\$$CFLAGS"|g ; \