aboutsummaryrefslogtreecommitdiffstats
path: root/audio/muse
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-01 19:56:11 +0800
committerbapt <bapt@FreeBSD.org>2012-06-01 19:56:11 +0800
commitb5b9e42c95a5e45505308f07e5167861af516e6c (patch)
tree5b346b21163ae745dc240fb5b5539f41e5fe6423 /audio/muse
parent5095712fe7d396fdfe86082d6f3a7476989d6058 (diff)
downloadfreebsd-ports-gnome-b5b9e42c95a5e45505308f07e5167861af516e6c.tar.gz
freebsd-ports-gnome-b5b9e42c95a5e45505308f07e5167861af516e6c.tar.zst
freebsd-ports-gnome-b5b9e42c95a5e45505308f07e5167861af516e6c.zip
Convert to new options framework, while here disable LAME by default to allow
packing distribution
Diffstat (limited to 'audio/muse')
-rw-r--r--audio/muse/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/audio/muse/Makefile b/audio/muse/Makefile
index d1870ddcb899..8872dd9193f3 100644
--- a/audio/muse/Makefile
+++ b/audio/muse/Makefile
@@ -8,7 +8,7 @@
PORTNAME= MuSE
PORTVERSION= 0.9.2
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= audio
MASTER_SITES= ftp://ftp.dyne.org/muse/releases/ \
http://www.ljudmila.org/~jaromil/muse/releases/
@@ -28,9 +28,8 @@ CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT -DHAVE_SYS_UIO_H \
${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lintl
-OPTIONS= X11 "Build with X11 support" on \
- MP3 "Build with MP3 support" on \
- SNDFILE "Build with sndfile support" on
+OPTIONS_DEFINE= X11 LAME SNDFILE
+OPTIONS_DEFAULT= X11
.include <bsd.port.pre.mk>
@@ -38,18 +37,18 @@ OPTIONS= X11 "Build with X11 support" on \
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-broken-scandir
.endif
-.if defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
+USE_GNOME+= gtk20
+.else
PKGNAMESUFFIX= -nox11
CONFIGURE_ARGS+=--without-x --with-rubik
-.else
-USE_GNOME+= gtk20
.endif
-.if !defined(WITHOUT_MP3) || exists(${LOCALBASE}/lib/libmp3lame.so.0)
+.if ${PORT_OPTIONS:MMP3} || exists(${LOCALBASE}/lib/libmp3lame.so.0)
LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
.endif
-.if !defined(WITHOUT_SNDFILE) || exists(${LOCALBASE}/lib/libsndfile.so.1)
+.if ${PORT_OPTIONS:MSNDFILE} || exists(${LOCALBASE}/lib/libsndfile.so.1)
LIB_DEPENDS+= sndfile.1:${PORTSDIR}/audio/libsndfile
.endif