aboutsummaryrefslogtreecommitdiffstats
path: root/audio/muse
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-07-08 18:22:14 +0800
committerijliao <ijliao@FreeBSD.org>2002-07-08 18:22:14 +0800
commit7061c825a5210c03732b321ec79be5b806d45809 (patch)
tree0b8baf7e1afe46bdc06d53d1075241021e654302 /audio/muse
parentcde117293fcf37aa19d9f54acecb0887be0a0d25 (diff)
downloadfreebsd-ports-gnome-7061c825a5210c03732b321ec79be5b806d45809.tar.gz
freebsd-ports-gnome-7061c825a5210c03732b321ec79be5b806d45809.tar.zst
freebsd-ports-gnome-7061c825a5210c03732b321ec79be5b806d45809.zip
PERL -> REINPLACE_CMD
PR: 39283 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Diffstat (limited to 'audio/muse')
-rw-r--r--audio/muse/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/audio/muse/Makefile b/audio/muse/Makefile
index feebca38d557..e16ee6a1a00a 100644
--- a/audio/muse/Makefile
+++ b/audio/muse/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
vorbis.1:${PORTSDIR}/audio/libvorbis \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+USE_REINPLACE= yes
USE_GTK= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -29,11 +30,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --disable-debug
post-patch:
- @${PERL} -pi -e 's|-O3|\$$CFLAGS|g ; \
+ @${REINPLACE_CMD} -e 's|-O3|\$$CFLAGS|g ; \
s|\$$GTK_LIBS -lgthread|\$$GTK_LIBS \$$GLIB_LIBS|g ; \
s|\$$GTK_FLAGS|\$$GTK_CFLAGS \$$GLIB_CFLAGS|g' \
${WRKSRC}/configure
- @${PERL} -pi -e 's|-lpthread||g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|-lpthread||g' ${WRKSRC}/Makefile.in
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/muse ${PREFIX}/bin