aboutsummaryrefslogtreecommitdiffstats
path: root/audio/musicpd
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-01-28 13:30:46 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-01-28 13:30:46 +0800
commitfff31c41e25f18f686e1df3f54ec72ceeae90261 (patch)
tree8f9d004269a151ed5aa5a7cc2e723e3167f5806c /audio/musicpd
parentd5abac560e3b85681179249b474ab1abf523e93e (diff)
downloadfreebsd-ports-gnome-fff31c41e25f18f686e1df3f54ec72ceeae90261.tar.gz
freebsd-ports-gnome-fff31c41e25f18f686e1df3f54ec72ceeae90261.tar.zst
freebsd-ports-gnome-fff31c41e25f18f686e1df3f54ec72ceeae90261.zip
- Update to 0.14
PR: ports/130612 Submitted by: Dylan Cochran <a134qaed@gmail.com> Approved by: Jan-Olof Lindqvist <jo.lindqvist@gmail.com> (maintainer)
Diffstat (limited to 'audio/musicpd')
-rw-r--r--audio/musicpd/Makefile26
-rw-r--r--audio/musicpd/distinfo6
-rw-r--r--audio/musicpd/pkg-plist5
3 files changed, 24 insertions, 13 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 502402be149e..a0e1896a5195 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= musicpd
-PORTVERSION= 0.13.2
+PORTVERSION= 0.14.1
CATEGORIES= audio ipv6
-MASTER_SITES= http://musicpd.org/uploads/files/ \
- http://redundancy.redundancy.org/mirror/
+MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME}
+
DISTNAME= mpd-${PORTVERSION}
MAINTAINER= jo.lindqvist@gmail.com
@@ -18,8 +18,11 @@ COMMENT= A remote-controllable music daemon
LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
+USE_GMAKE= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
+USE_GNOME= glib20
+
USE_RC_SUBR= musicpd.sh
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -47,6 +50,7 @@ OPTIONS= FLAC "Support FLAC audio format" on \
PULSEAUDIO "Support PulseAudio sound server" off \
JACK "Support JACK audio server" off \
SHOUTCAST "Support for Icecast and Shoutcast" off \
+ LAME "Support for MP3 Icecast Streams" off \
SAMPLERATE "Support sample rate conversion" off
.include <bsd.port.pre.mk>
@@ -69,18 +73,22 @@ CONFIGURE_ARGS+=--with-tremor
LIB_DEPENDS+= vorbisidec.1:${PORTSDIR}/audio/libtremor
.endif
-.if defined(WITHOUT_WAV)
-CONFIGURE_ARGS+=--disable-audiofile
-.else
-LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
-.endif
-
.if defined(WITH_AAC)
LIB_DEPENDS+= faad.0:${PORTSDIR}/audio/faad
.else
CONFIGURE_ARGS+=--disable-aac
.endif
+.if defined(WITH_LAME)
+LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
+.endif
+
+.if defined(WITHOUT_WAV)
+CONFIGURE_ARGS+=--disable-audiofile
+.else
+LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
+.endif
+
.if defined(WITH_MUSEPACK)
LIB_DEPENDS+= mpcdec.5:${PORTSDIR}/audio/libmpcdec
.else
diff --git a/audio/musicpd/distinfo b/audio/musicpd/distinfo
index 1cbc20550ae6..eee08e5d7f63 100644
--- a/audio/musicpd/distinfo
+++ b/audio/musicpd/distinfo
@@ -1,3 +1,3 @@
-MD5 (mpd-0.13.2.tar.bz2) = b461896369949ff3cff955692ead9f8b
-SHA256 (mpd-0.13.2.tar.bz2) = d98db80ec0bba7d4a82a8aecff965f6887f7b055ad064d8d5ccb55cc614cdfb5
-SIZE (mpd-0.13.2.tar.bz2) = 413347
+MD5 (mpd-0.14.1.tar.bz2) = 4bc78cbc64728cddb0ace81867565204
+SHA256 (mpd-0.14.1.tar.bz2) = b7e1fc95701a84583077def6e1c507e2bfb759aa42e04d1eca498094bf0fc694
+SIZE (mpd-0.14.1.tar.bz2) = 286850
diff --git a/audio/musicpd/pkg-plist b/audio/musicpd/pkg-plist
index 360f781cac4f..1bd37c5ffd37 100644
--- a/audio/musicpd/pkg-plist
+++ b/audio/musicpd/pkg-plist
@@ -1,7 +1,10 @@
bin/mpd
-%%PORTDOCS%%%%DOCSDIR%%/COMMANDS
%%PORTDOCS%%%%DOCSDIR%%/mpdconf.example
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTDOCS%%@unexec %D/%%DOCSDIR%% 2>/dev/null || true