aboutsummaryrefslogtreecommitdiffstats
path: root/audio/nas/Makefile
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-12-31 02:15:33 +0800
committerpetef <petef@FreeBSD.org>2001-12-31 02:15:33 +0800
commit29508a7ae1fc6a692a7777ab520322db11979ca8 (patch)
tree4a69b5255e256b02c1a81cdeb14ff7374a70d195 /audio/nas/Makefile
parenta93a0da488111b051fa1788e1dedfc80bdb4b581 (diff)
downloadfreebsd-ports-gnome-29508a7ae1fc6a692a7777ab520322db11979ca8.tar.gz
freebsd-ports-gnome-29508a7ae1fc6a692a7777ab520322db11979ca8.tar.zst
freebsd-ports-gnome-29508a7ae1fc6a692a7777ab520322db11979ca8.zip
- update to 1.5
- update MASTER_SITES - split manpages out into Makefile.man - print out PKGMESSAGE better PR: 33333 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Diffstat (limited to 'audio/nas/Makefile')
-rw-r--r--audio/nas/Makefile63
1 files changed, 8 insertions, 55 deletions
diff --git a/audio/nas/Makefile b/audio/nas/Makefile
index e585c5533e17..733ef8aa1367 100644
--- a/audio/nas/Makefile
+++ b/audio/nas/Makefile
@@ -6,75 +6,28 @@
#
PORTNAME= nas
-PORTVERSION= 1.4.1
+PORTVERSION= 1.5
CATEGORIES= audio
-MASTER_SITES= http://radscan.com/nas/ \
- ${MASTER_SITE_XCONTRIB}
-MASTER_SITE_SUBDIR= audio/nas
+MASTER_SITES= http://radscan.com/nas/
EXTRACT_SUFX= .src.tar.gz
MAINTAINER= ports@FreeBSD.org
USE_IMAKE= yes
-INSTALLS_SHLIB= yes
ALL_TARGET= World
# no need to "xmkmf -a" and create the Makefiles twice -- see above
XMKMF= xmkmf
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.pre.mk>
-MAN1= auconvert.1 auctl.1 audemo.1 audial.1 auedit.1 auinfo.1 aupanel.1 \
- auphone.1 auplay.1 aurecord.1 auscope.1 autool.1 auvoxware.1 auwave.1 \
- checkmail.1 issndfile.1 nas.1 nasd.1 nasd.conf.1 playbucket.1 soundtoh.1
-MAN3= AuAnyEvent.3 AuBucketAttributes.3 AuCloseServer.3 \
- AuConvertDataToShort.3 AuConvertShortToData.3 AuCreateBucket.3 \
- AuCreateFlow.3 AuDataFormats.3 AuDataTypes.3 AuDefineToFormat.3 \
- AuDestroyBucket.3 AuDestroyFlow.3 AuDeviceAttributes.3 \
- AuDispatchEvent.3 AuElement.3 AuElementNotifyEvent.3 \
- AuElementParameters.3 AuElementState.3 AuErrorEvent.3 AuEvent.3 \
- AuEventsQueued.3 AuFileFormats.3 AuFixedPointFractionalAddend.3 \
- AuFixedPointFromFraction.3 AuFixedPointFromSum.3 \
- AuFixedPointIntegralAddend.3 AuFixedPointRoundDown.3 \
- AuFixedPointRoundUp.3 AuFlush.3 AuFormatToDefine.3 AuFormatToString.3 \
- AuFreeBucketAttributes.3 AuFreeDeviceAttributes.3 \
- AuFreeElementStates.3 AuFreeElements.3 AuGetBucketAttributes.3 \
- AuGetCloseDownMode.3 AuGetDeviceAttributes.3 AuGetElementParameters.3 \
- AuGetElementStates.3 AuGetElements.3 AuGetErrorDatabaseText.3 \
- AuGetErrorText.3 AuGetScratchFlow.3 AuGetScratchFlowFromBucket.3 \
- AuGetScratchFlowToBucket.3 AuGetServerTime.3 AuGrabNotifyEvent.3 \
- AuHandleEvents.3 AuIDOfEvent.3 AuInputTrack.3 AuKillClient.3 \
- AuListBuckets.3 AuListDevices.3 AuLookupEventHandler.3 \
- AuMakeChangeStateAction.3 AuMakeElementAddConstant.3 \
- AuMakeElementBundle.3 AuMakeElementExportBucket.3 \
- AuMakeElementExportClient.3 AuMakeElementExportDevice.3 \
- AuMakeElementExportMonitor.3 AuMakeElementImportBucket.3 \
- AuMakeElementImportClient.3 AuMakeElementImportDevice.3 \
- AuMakeElementImportWaveForm.3 AuMakeElementMultiplyConstant.3 \
- AuMakeElementState.3 AuMakeElementSum.3 AuMakeInputTrack.3 \
- AuMakeNoopAction.3 AuMakeSendNotifyAction.3 AuMonitorDevice.3 \
- AuMonitorNotifyEvent.3 AuNextEvent.3 AuOpenServer.3 AuPauseFlow.3 \
- AuReadElement.3 AuRegisterEventHandler.3 AuReleaseScratchFlow.3 \
- AuRequeueEvent.3 AuScanEvents.3 AuScanForTypedEvent.3 AuServer.3 \
- AuServerName.3 AuSetBucketAttributes.3 AuSetCloseDownMode.3 \
- AuSetDeviceAttributes.3 AuSetElementParameters.3 AuSetElementStates.3 \
- AuSetElements.3 AuSetErrorHandler.3 AuSetIOErrorHandler.3 \
- AuSetString.3 AuSoundCreateBucketFromData.3 \
- AuSoundCreateBucketFromFile.3 AuSoundCreateDataFromBucket.3 \
- AuSoundCreateFileFromBucket.3 AuSoundPlay.3 AuSoundPlayFromBucket.3 \
- AuSoundPlayFromData.3 AuSoundPlayFromFile.3 \
- AuSoundPlaySynchronousFromFile.3 AuSoundRecord.3 \
- AuSoundRecordToBucket.3 AuSoundRecordToData.3 AuSoundRecordToFile.3 \
- AuSoundRecordToFileN.3 AuStartFlow.3 AuStopFlow.3 AuStringToFormat.3 \
- AuStringToWaveForm.3 AuSync.3 AuSynchronize.3 \
- AuUnregisterEventHandler.3 AuWaveFormToString.3 AuWriteElement.3 \
- Sound.3 SoundAbbrevToFileFormat.3 SoundCloseFile.3 SoundCreate.3 \
- SoundFlushFile.3 SoundOpenFileForReading.3 SoundOpenFileForWriting.3 \
- SoundReadFile.3 SoundRewindFile.3 SoundSeekFile.3 \
- SoundStringToFileFormat.3 SoundTellFile.3 SoundWriteFile.3
+.include "${.CURDIR}/Makefile.man"
post-patch:
@find ${WRKSRC} -name '*.[ch]' | xargs \
${PERL} -pi -e "s|<malloc.h>|<stdlib.h>|g"
post-install:
- @${CAT} ${PKGMESSAGE}
+ @${SED} -e 's:/usr/X11R6:${PREFIX}:g' ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>