aboutsummaryrefslogtreecommitdiffstats
path: root/audio/ncmpcpp
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-06 23:34:17 +0800
committerbapt <bapt@FreeBSD.org>2013-05-06 23:34:17 +0800
commit8125658176eb2b6a00216bc61058e31e8d19d160 (patch)
tree5b19e4fae39149280653cc670bc170d039477f8e /audio/ncmpcpp
parent4ca6469bebf737a13fe9257550d791b2fdc61200 (diff)
downloadfreebsd-ports-gnome-8125658176eb2b6a00216bc61058e31e8d19d160.tar.gz
freebsd-ports-gnome-8125658176eb2b6a00216bc61058e31e8d19d160.tar.zst
freebsd-ports-gnome-8125658176eb2b6a00216bc61058e31e8d19d160.zip
Convert USE_NCURSES by USES=ncurses
Convert USE_READLINE by USES=readline
Diffstat (limited to 'audio/ncmpcpp')
-rw-r--r--audio/ncmpcpp/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/audio/ncmpcpp/Makefile b/audio/ncmpcpp/Makefile
index a345a90c2d29..84e9e33723d8 100644
--- a/audio/ncmpcpp/Makefile
+++ b/audio/ncmpcpp/Makefile
@@ -13,10 +13,9 @@ COMMENT= A ncurses mpd client, clone of ncmpc with some new features
LIB_DEPENDS= mpdclient:${PORTSDIR}/audio/libmpdclient \
fftw3:${PORTSDIR}/math/fftw3
-USES= iconv
+USES= iconv ncurses
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_NCURSES= yes
USE_GNOME= glib20
USE_AUTOTOOLS= automake aclocal libtool
ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
@@ -36,11 +35,6 @@ VISUALIZER_DESC= Enable music visualizer screen
.include <bsd.port.options.mk>
-.if defined(WITH_NCURSES_BASE)
-# no need to use ncurses-config if we use ncurses from the base system
-CONFIGURE_ARGS+= NCURSES_CONFIG=/usr/bin/true
-.endif
-
PLIST_FILES= bin/ncmpcpp \
%%DOCSDIR%%/config \
%%DOCSDIR%%/keys \
@@ -86,6 +80,13 @@ BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
CONFIGURE_ARGS+= --enable-visualizer
.endif
+.include <bsd.port.pre.mk>
+
+.if ${NCURSESBASE} == /usr
+# no need to use ncurses-config if we use ncurses from the base system
+CONFIGURE_ARGS+= NCURSES_CONFIG=/usr/bin/true
+.endif
+
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/ncmpcpp ${PREFIX}/bin/
.if ${PORT_OPTIONS:MDOCS}
@@ -102,4 +103,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG} ""
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>