aboutsummaryrefslogtreecommitdiffstats
path: root/audio/ocp
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2007-04-25 20:24:55 +0800
committerehaupt <ehaupt@FreeBSD.org>2007-04-25 20:24:55 +0800
commite704d2a6315fae40320ac772f066d97c86d9fa2a (patch)
tree2c1e5d44fb545cbc2613177218d8ffeb8dff6025 /audio/ocp
parent2209d039774385d30bfc2e7476a38d3831d2b415 (diff)
downloadfreebsd-ports-gnome-e704d2a6315fae40320ac772f066d97c86d9fa2a.tar.gz
freebsd-ports-gnome-e704d2a6315fae40320ac772f066d97c86d9fa2a.tar.zst
freebsd-ports-gnome-e704d2a6315fae40320ac772f066d97c86d9fa2a.zip
Refine last commit. ocp seems to need wide character support in order to
display colors correctly. However, devel/ncurses is not needed after 602107 and 700033 since it's already in the base.
Diffstat (limited to 'audio/ocp')
-rw-r--r--audio/ocp/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/audio/ocp/Makefile b/audio/ocp/Makefile
index 8a02d902c62d..d147ea013e32 100644
--- a/audio/ocp/Makefile
+++ b/audio/ocp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ocp
PORTVERSION= 0.1.13
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://stian.lunafish.org/ocp/ \
http://critical.ch/distfiles/ \
@@ -19,8 +19,7 @@ COMMENT= The legendary Open Cubic Player
LIB_DEPENDS= id3tag.0:${PORTSDIR}/audio/libid3tag \
mad.2:${PORTSDIR}/audio/libmad \
vorbis.3:${PORTSDIR}/audio/libvorbis \
- sidplay.1:${PORTSDIR}/audio/libsidplay \
- ncursesw.5:${PORTSDIR}/devel/ncurses
+ sidplay.1:${PORTSDIR}/audio/libsidplay
ONLY_FOR_ARCHS= i386
@@ -79,6 +78,10 @@ PLIST_SUB+= ADPLUG="@comment "
CONFIGURE_ARGS+= --without-adplug
.endif
+.if ${OSVERSION} < 602107 || (${OSVERSION} > 700000 && ${OSVERSION} < 700033)
+LIB_DEPENDS+= ncursesw.5:${PORTSDIR}/devel/ncurses
+.endif
+
pre-everything::
.if !exists(${TIMIDITY_CFG}) && !defined(WITHOUT_MIDI)
@${ECHO_MSG} ""
@@ -114,13 +117,15 @@ post-patch:
${WRKSRC}/filesel/adb.c \
${WRKSRC}/filesel/pfilesel.c
-# use ncurses
+.if ${OSVERSION} < 602107 || (${OSVERSION} > 700000 && ${OSVERSION} < 700033)
+# use ncursesw from ports
@${REINPLACE_CMD} -e 's|-l\(curses\)|-ln\1w|' ${WRKSRC}/stuff/Makefile
.for f in ${PFILES}
@${REINPLACE_CMD} -e \
's|#include.*<curses\.h.*|#include <ncurses/ncurses.h>|' \
${WRKSRC}/${f}
.endfor
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ocp ${PREFIX}/bin