aboutsummaryrefslogtreecommitdiffstats
path: root/audio/openal-soft/files
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-10-19 15:28:28 +0800
committermva <mva@FreeBSD.org>2014-10-19 15:28:28 +0800
commitebd90c4793a440c440de7d00275eba29c42d7c77 (patch)
tree6d91eed5cfcdfbe6f5f6dd0371358033c43d2f10 /audio/openal-soft/files
parent53999cf2783e60b1295a64d20d643ac735ffb8be (diff)
downloadfreebsd-ports-gnome-ebd90c4793a440c440de7d00275eba29c42d7c77.tar.gz
freebsd-ports-gnome-ebd90c4793a440c440de7d00275eba29c42d7c77.tar.zst
freebsd-ports-gnome-ebd90c4793a440c440de7d00275eba29c42d7c77.zip
- Update to version 1.16.0
This version provides * additional and improved effects * high- and band-pass EFX filters * improved resampling support * improved audio back-end support * a GUI configuration utility (based on QT) * and lots of other features: http://kcat.strangesoft.net/openal.html
Diffstat (limited to 'audio/openal-soft/files')
-rw-r--r--audio/openal-soft/files/patch-Alc-ALu.c37
-rw-r--r--audio/openal-soft/files/patch-CMakeLists.txt30
2 files changed, 25 insertions, 42 deletions
diff --git a/audio/openal-soft/files/patch-Alc-ALu.c b/audio/openal-soft/files/patch-Alc-ALu.c
deleted file mode 100644
index 75b767f31d96..000000000000
--- a/audio/openal-soft/files/patch-Alc-ALu.c
+++ /dev/null
@@ -1,37 +0,0 @@
---- Alc/ALu.c.orig 2013-05-23 08:00:01.000000000 +0200
-+++ Alc/ALu.c 2013-05-23 08:01:20.000000000 +0200
-@@ -912,24 +912,27 @@
- }
-
-
--static __inline ALfloat aluF2F(ALfloat val)
--{ return val; }
--static __inline ALint aluF2I(ALfloat val)
-+static __inline ALint aluF2I25(ALfloat val)
- {
- /* Clamp the value between -1 and +1. This handles that without branching. */
- val = val+1.0f - fabsf(val-1.0f);
- val = (val-2.0f + fabsf(val+2.0f)) * 0.25f;
-- /* Convert to a signed integer, between -2147483647 and +2147483647. */
-- return fastf2i((ALfloat)(val*2147483647.0));
-+ /* Convert to a signed integer, between -16777215 and +16777215. */
-+ return fastf2i(val*16777215.0f);
- }
-+
-+static __inline ALfloat aluF2F(ALfloat val)
-+{ return val; }
-+static __inline ALint aluF2I(ALfloat val)
-+{ return aluF2I25(val)<<7; }
- static __inline ALuint aluF2UI(ALfloat val)
- { return aluF2I(val)+2147483648u; }
- static __inline ALshort aluF2S(ALfloat val)
--{ return aluF2I(val)>>16; }
-+{ return aluF2I25(val)>>9; }
- static __inline ALushort aluF2US(ALfloat val)
- { return aluF2S(val)+32768; }
- static __inline ALbyte aluF2B(ALfloat val)
--{ return aluF2I(val)>>24; }
-+{ return aluF2I25(val)>>17; }
- static __inline ALubyte aluF2UB(ALfloat val)
- { return aluF2B(val)+128; }
-
diff --git a/audio/openal-soft/files/patch-CMakeLists.txt b/audio/openal-soft/files/patch-CMakeLists.txt
index 723a700b56c9..3d83e5817d4e 100644
--- a/audio/openal-soft/files/patch-CMakeLists.txt
+++ b/audio/openal-soft/files/patch-CMakeLists.txt
@@ -1,8 +1,28 @@
---- CMakeLists.txt.orig 2011-02-15 21:05:40.000000000 +0100
-+++ CMakeLists.txt 2011-02-17 21:52:49.000000000 +0100
-@@ -270,10 +270,6 @@
+--- CMakeLists.txt.orig 2014-08-15 07:06:59 UTC
++++ CMakeLists.txt
+@@ -62,8 +62,8 @@
+ SET(LIBNAME openal)
- CHECK_LIBRARY_EXISTS(pthread pthread_setschedparam "" HAVE_PTHREAD_SETSCHEDPARAM)
+ # These are needed on non-Windows systems for extra features
+- ADD_DEFINITIONS(-D_GNU_SOURCE=1 -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=700)
+- SET(CMAKE_REQUIRED_FLAGS "${CMAKE_REQUIRED_FLAGS} -D_GNU_SOURCE=1 -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=700")
++ ADD_DEFINITIONS(-D_GNU_SOURCE=1)
++ SET(CMAKE_REQUIRED_FLAGS "${CMAKE_REQUIRED_FLAGS} -D_GNU_SOURCE=1")
+ ENDIF()
+
+ # Set defines for large file support
+@@ -186,7 +186,7 @@
+ # Check if we have C11 _Atomic
+ CHECK_C_SOURCE_COMPILES(
+ "#include <stdatomic.h>
+- int _Atomic foo;
++ const int _Atomic foo = ATOMIC_VAR_INIT(~0);
+ int main()
+ {
+ return atomic_load(&foo);
+@@ -523,10 +523,6 @@
+
+ CHECK_SYMBOL_EXISTS(pthread_mutex_timedlock pthread.h HAVE_PTHREAD_MUTEX_TIMEDLOCK)
- CHECK_LIBRARY_EXISTS(rt clock_gettime "" HAVE_LIBRT)
- IF(HAVE_LIBRT)
@@ -11,7 +31,7 @@
ENDIF()
# Check for a 64-bit type
-@@ -502,7 +498,7 @@
+@@ -1108,7 +1104,7 @@
DESTINATION include/AL
)
INSTALL(FILES "${OpenAL_BINARY_DIR}/openal.pc"