aboutsummaryrefslogtreecommitdiffstats
path: root/audio/openal
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-07-27 07:46:21 +0800
committerbapt <bapt@FreeBSD.org>2013-07-27 07:46:21 +0800
commita06be5ff99fe983cee1b8e376f05782297a7f40f (patch)
tree818943fb55d2a9443eda5e445946d101fc6902af /audio/openal
parent89eb0b13f1f804eccec204b2aede7e064fbe7717 (diff)
downloadfreebsd-ports-gnome-a06be5ff99fe983cee1b8e376f05782297a7f40f.tar.gz
freebsd-ports-gnome-a06be5ff99fe983cee1b8e376f05782297a7f40f.tar.zst
freebsd-ports-gnome-a06be5ff99fe983cee1b8e376f05782297a7f40f.zip
Chase audio/arts removal
Diffstat (limited to 'audio/openal')
-rw-r--r--audio/openal/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/audio/openal/Makefile b/audio/openal/Makefile
index 7e90ed847eef..b7659cebff70 100644
--- a/audio/openal/Makefile
+++ b/audio/openal/Makefile
@@ -17,13 +17,13 @@ USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --enable-capture
-USE_GMAKE= yes
-USES= pathfix pkgconfig
+CONFIGURE_ARGS= --enable-capture \
+ --disable-arts
+USES= pathfix pkgconfig gmake
WANT_SDL= yes
USE_LDCONFIG= yes
-OPTIONS_DEFINE= ARTS ESOUND SDL VORBIS SMPEG
+OPTIONS_DEFINE= ESOUND SDL VORBIS SMPEG
OPTIONS_DEFINE_i386= ASM
OPTIONS_DEFAULT_i386= ASM
SMPEG_DESC= smpeg support
@@ -34,13 +34,6 @@ SMPEG_DESC= smpeg support
WITH_SDL= yes # smpeg requires SDL
.endif
-.if ${PORT_OPTIONS:MARTS}
-LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
-CONFIGURE_ARGS+=--enable-arts
-.else
-CONFIGURE_ARGS+=--disable-arts
-.endif
-
.if ${PORT_OPTIONS:MESD}
USE_GNOME+= esound
CONFIGURE_ARGS+=--enable-esd